Upgraded to 1.35.3 but DB not syncing and relay not receiving incoming connections?


I upgraded to 1.35.3 on both my BP and relay, as per:

Issue #1 (BP stuck in “starting”)
It was sitting on epoch 0 for about 3 days and in the starting status.

I tried deleting/moving the DB folder to let it redownload the blockchain (as noted at the end of the guide), however it creates the files for it (immutable, ledger, volatile etc) but it does NOT actually download anything. (I presume because the relay also isn’t working 100%?)

Interesting logs from BP:

blink-bp cardano-node[1299891]: [blink-bp:cardano.node.DnsSubscription:Warning:71] [2022-08-28 09:27:07.84 UTC] Domain: “relaystakepool.ddns.net” Failed to start all required subscriptions

Aug 28 05:27:11 blink-bp cardano-node[1299891]: [blink-bp:cardano.node.Mux:Info:2222156] [2022-08-28 09:27:11.27 UTC] Bearer on ConnectionId {localAddress =, remoteAddress =} event: State: Dead

Aug 28 05:27:11 blink-bp cardano-node[1299891]: [blink-bp:cardano.node.ErrorPolicy:Warning:76] [2022-08-28 09:27:11.27 UTC] IP ErrorPolicySuspendPeer (Just (ApplicationExceptionTrace (MuxError (MuxIOException Network.Socket.recvBuf: resource vanished (Connection reset by peer)) “(recv errored)”))) 20s 20s

Issue #2
The relay appears to be up to date and syncing, however gliveview says I have 0 incoming connections and 12 outgoing…

I’ve tried EVERYTHING to understand why this is happening, but it looks like it’s offline (pooltools.io etc)

Here’s a curious log from the relay:

Aug 28 05:19:25 blink cardano-node[496793]: [blink:cardano.node.ErrorPolicy:Notice:434] [2022-08-28 09:19:25.85 UTC] IP ErrorPolicySuspendConsumer (Just (ConnectionExceptionTrace Network.Socket.connect: <socket: 41>: timeout (Connection timed out))) 20s

I did update (only now) the CNODE_HOSTNAME to point to relay addr, is this correct? (Hopefully this isn’t creating more problems lol).

ANY assistance would be GREATLY appreciated

Looks like my relay’s IP changed, RIGHT as I upgraded coincidently…

After updating the port forwarding in my router, the relay began to receive incoming connections… and now my BP is syncing.

All is well!


Keep in mind that you’re using ddns.net, which while it does update IP changes against the DNS record, it won’t update your nodes. When cardano-node starts up, it does a lookup of the domain, it resolves the IP, and then connects using the IP.

The issue you will face is that if your IP changes, you will need to restart your cardano-node for it to resolve the IP address again and point to the new IP.