BP and Relay stuck after the sync

Hello all,
I’m building a BP node and relay node on mainnet. I already worked about this on testnet and everything worked fine.

Now I’m facing this issue:

I ran the nodes and they got synced to the blockchain. Everything worked without the issues.
After the sync was completed, I wanted to test the nodes restart: from that moment they are both stuck during the start. This is what I see from gLiveView.sh:

Looks like cardano-node is running with socket-path as /home/alessio/cardano-my-node/db/socket, but the actual socket file does not exist.
This could occur if the node hasnt completed startup or if a second instance of node startup was attempted!
If this does not resolve automatically in a few minutes, you might want to restart your node and try again.

Connection to node lost, retrying (1/3)!

Before the “sudo systemctl restart cardano-node” everything was perfect.
This is the second time in a row it happens. Why?
I also tried to manually start the scripts but they did not create the socket file.
Did someone have the same issue?

Thank you all for your time.

Be patient… it will take more minutes to start ~10 or 15 minutes (depends on HW configuration)

if u have only one relay then it must start first… then the Producer (the Producer will not start if can’t connect to relay)

Ok Alex thank you!! I was worrying :slight_smile:
By the way they both have 16G memory and 2CPU

I will let you know, thank you for your reply!

1 Like

It worked as u said!!! Many thanks man!!

1 Like

You are welcome :beers: