Producer node stuck after making VRF key pair

Hello everyone,

I’m having a problem using the coincashew guide.

My block producer node has been running and fully synced without any problems for a long time but after the commands shown in the screenshots, The status stays on “activating”
and gLiveVIew is stuck on starting with a “syntax error” as you can see.

Screenshot from 2021-06-21 18-48-57

Screenshot from 2021-06-21 18-49-40

Can anyone explain why this happened and how to fix this problem? Thank you.

journalctl -e -f -u cardano-node and check the error

Or try to start the node manually

“home/owen/cardano-my-node/node.cert: /home/owen/cardano-my-node/node.cert: openBinaryFile: does not exist (No such file or directory)”

Is the only thing it keeps repeating.

You mean with the command?

“sudo systemctl start cardano-node”

I did and it did not seem to work.

Ok, it seems u must use the full path to the files inside the script

1 Like

I don’t understand where the emboldended part came from.

“home/owen/cardano-my-node/node.cert: /home/owen/cardano-my-node/node.cert

I don’t have a file named “cardano-my-node”

The node.cert file is inside of cardano-node and not in cardano-my-node because that doesn’t exist. Where can I change the path directory and what command is the best for this?

Inside the script

I messed up actually, I was looking at my servers terminal and not the block producer. So the error was correct in saying that it could not find the node.cert file because it wasn’t on my producer node…

I seemed to get the node running again but now I’m getting this error when I try to monitor via gLiveView.

Screenshot from 2021-06-21 21-23-31

If u type top do u see CPU ~100% for cardano-node process?
wait more minutes and try again in glive

1 Like

If you had had the BP running and then you regenerated the vrf key pair, you’ll not be able to mint blocks.

No I stopped it before I did that.

You’ll still not be able to mint any blocks if your vrfs have been regenerated.

The cardano-node process is at <1%CPU and 48%MEM usage.

and how is the glive?

Problem solved! :slight_smile:

1 Like

Started as a Producer?

Yes it’s up and running again thank you very much

1 Like