Register Address error

Hi to all. I´m new in this world of cardano trying to build a pool. I just created 1 Relay node and 1 Prod node but I get an error when I try to register stake address. I have realised that KES expiration is the same as when I created the Keys so I created them again to tro to renew but same thing.
Any idea what can I be doing wrong?

Many thanks for your help in advance.


Can u share the error with us?


I´m sorry. I thought that was into the message.

This is the relay

Many thanks in advance

Are u running topology updater script on your relay? I see no IN connections ; only your BP

Show me how u build and sign the transaction (script) please

No I didn´t run that script. I have used guide from CoinCashew at Guide: How to build a Cardano Stake Pool - CoinCashew
is it needed to run that script on my Relay node?

Many thanks

Yes, on BP u added your relay manually? But on relay you need to run topology updater script in order to announce your relay into the network

Yes I added the relay manually on BP.
Are the instructions at Download and Configure - guild-operators - Cardano Updates correct to run the updater scritp on relay?
Many thanks

1 Like

Yes, try from this link

I run the script with the Config into env and got the msg “Nice to meet you”
Should I try to register Stake address again? I should renew KES keys due to the expiration date shown in the last image? This is the actual relay
This is the image of the relay after running the script. It still has got only one IN connection.

Many thanks

Added in crontab? The script needs to run 1/hour (always; do not stop after)

After 3 run (4 hours u should see glade u are staying with us) then restart ur relay and tx should be increasing…

And yes you need to generate new kes

Yes I added to crontab to run each hor. So will restart within 4 hours.
Thank you very much for your quick and good help.

You are welcome, after u will generate new kes, restart ur BP

Ok I will.
Ca I generate new KES with the steps I did before to create the first ones? or do I need to follow something different?
Any idea why the expiration date is just the same as the creation time?


I don’t know… wait to check the quide

Ok, start with step 9 from the guide

cardano-cli node key-gen-KES
–verification-key-file kes.vkey
–signing-key-file kes.skey

ok, done.
Thank you very much. I will continue when see IN connections.


1 Like

did you renewed the KEYS? everything ok?they should be valid 90 days from now.


1 Like

Hello again.
Thank you very much for your help. It has been working during this weekend with the new KEYS but I have an issue with the updater script. When I configure it into crontab it does not run, I have to run it manually, but today I got a question to update it to a new version and now I get this error message ./ line 300: return: can only `return’ from a function or sourced script
Any idea what can be happening?

This is the actual view of the NODE.
Next step is going to register the pool today.

Many thanks


I had also this behavior after an update. (each time when an update is performed, some files are renew (the old files are bkped) and you must review/edit them)
Please check the files:

nano env - check everything is fine
nano - check if everything is fine
check - check if everything is fine
check topology.json file - check if everything is fine

if these files have the default configuration, you must edit them again (you can compare with the bkped file)

how did you configured the topologyupdater script in crontab ? and what rights/permisions has the script?


I just checked before the settings of the new env and updated with the same as before. is configured with the correct settings and topology hasn´t got any change…

It´s happening the same when I run the update og gLiveView, it doesn´t work after update it. I had to restore back with the old files.