Relay Node not talking with my core Node

Here are the logs they appear time to time in relay logs:

there is no metrics in grafana that’s so weired firwall is configured properly
even my core node is in sync with relay but same issue maybe for some reason relay node allows to sync but there is also these logs…

Also my pool not showing up in wallets like yoroi daedalus wallet

[relay:cardano.node.IpSubscription:Info:64] [2021-01-25 23:31:31.22 UTC] IPs: 0.0.0.0:0 [X.X.X.X:3000] Trying to connect to X.X.X.X:PORT
[relay:cardano.node.IpSubscription:Info:562] [2021-01-25 23:31:31.22 UTC] IPs: 0.0.0.0:0 [X.X.X.X:3000] Connection Attempt Start, destination X.X.X.X:PORT
[relay:cardano.node.IpSubscription:Notice:64] [2021-01-25 23:31:31.22 UTC] IPs: 0.0.0.0:0 [X.X.X.X:3000] Waiting 0.025s before attempting a new connection
[relay:cardano.node.IpSubscription:Notice:562] [2021-01-25 23:31:31.30 UTC] IPs: 0.0.0.0:0 [X.X.X.X:3000] Connection Attempt End, destination X.X.X.X:PORT outcome: ConnectSuccessLast
[relay:cardano.node.IpSubscription:Info:562] [2021-01-25 23:31:31.48 UTC] IPs: 0.0.0.0:0 [X.X.X.X:3000] Closed socket to X.X.X.X:PORT

Hello,

When did u installed the nodes?
What is ur ticker?
What guide did u follow?
Are u using cntool?

Cheers?

if your stake pool not showing up in Yoroi check it at other places, like pooltool.io.
Could you fetch your pool id from the ledger state?
cardano-cli query ledger-state --mainnet --allegra-era | grep publicKey | grep "<your pool_id>"
you can check your port whether is open or not, with netcat -vnz <node_ip> <node_port>

Pool ASHA [ASHA] that’s my ticker

Capture

I’m using ubuntu on both nodes…

I followed both these tutorials:
https://cardano-foundation.gitbook.io/stake-pool-course/stake-pool-guide/getting-started/install-node

https://docs.cardano.org/projects/cardano-node/en/latest/getting-started/install.html

Core NODE:
cardano-node run --topology mainnet-topology.json --database-path db --socket-path db/node.socket --host-addr 0.0.0.0 --port 3000 --config mainnet-config.json --shelley-kes-key kes.skey --shelley-vrf-key vrf.skey --shelley-operational-certificate node.cert

RELAY:
cardano-node run
–topology mainnet-topology.json
–database-path db
–socket-path db/node.socket
–host-addr 0.0.0.0
–port 3001
–config mainnet-config.json

That’s how I’m starting both nodes… & I’m using digital ocean

Hello,

I checked for ASHA and it looks ok on adapools, pooltool, daedalus view but indeed I can’t find it on Yoroi

I don’t know how u registered the pool, I see your relay is registered with port 3000 but u are starting with port 3001

Is this your relay IP: 161.35.184.24 ? anyway it has both port 3000 and 3001 closed, please check if you are accepting incoming connections but check which port you will use 3000 or 3001 ?

Cheers,

delete ur last post, please hide your BP IP

on adapools I can see u registered the relay with:

3000 161.35.184.24

No worries I can restart it will auto change to new IP address & also keys are in colde storage only cert of stake is on my core node.

should I re register?

OOO man, you don’t have a static IP? do you use a dynamic IP?

it’s static on digital ocean when we start server but If close & turn it off & restart it will change the IP address

what should I do? re register pool with this new relay IP?

exactly that’s meaning is not static… and you should fix this first because everytime when your IP will change, you need to register again the relay, you need to modify to topology configuration file, you need to wait again 4 hours (topology updater script) in order for your new IP to be live into the network, etc…

it is not recommended to have a dynamic IP

Please fix this first!

Cheers,

ok thanks I thought relay IP is never registered… I’ll do this now… & I’ll update here accordingly

1 Like

one more question which one should I use to register pool relay server or core server?

pool relay? no… when u are registering your pool, also you will register the relay IP and port…
What do you mean by pool relay?

yes, you were right I forget…

Well I just re-registered the pool can you check … still the error is present But I think it might be solved after update

Hello,

Looks fine now,

I can find your pool in yoroi:

WhatsApp Image 2021-01-26 at 15.12.55

  • on relay you will need to run the topologyupdater script 1/hour
  • on Producer you will need to edit manually your relay IP (no run topology updater)

to be sure everything is working fine on your PRoducer, you should see infos about KES, blocks, tx incrementing, etc

Cheers,

how do I run topology updater? can you send me any link to that you are very helpful man

read first about it, you should run only on relay


#CUSTOM_PEERS=“None” – here you will add your Producer IP and port for eg: “10.0.0.1:3001”

and perhaps you will neet to edit the env file with your paths

Cheers,