Relay Node no longer connecting to Peers

Hi there - can anyone advise why my relay node is no longer connecting to Peers. It has been running fine for a couple of weeks but has suddenly stopped connecting. I have made no changes to any configurations. When I monitor it I can see several peers appearing for a few seconds and then they just disappear again. Also the Block Producing Node disappears and reappears as well every now and then. I have tried stopping and starting both nodes but no change. Any advice is appreciated. Many thanks.

Problem solved NFA

What was the issue in the end and how did know about the number of conneted peers to your nodes ? I’m just curious.

Thanks

I updated the relay node topology files by following the steps in Coincashew notes. This appeared to do the trick and when I restarted the nodes all the relays came back. I think what happened was that I took a snapshot of my VM’s in Virtual Box with the nodes both running and this somehow corrupted the relay node - so I updated the topology files and everything is working fine. I trust this makes sense.

Happy to hear you solved. Have you ever considered using docker instead of VMs with VirtualBox?

They sound interesting but never used them and I would have to learn from scratch. I am guessing there would be quite a steep learning curve.