Both Relays Offline After 1.29 update

Hello again!

I’m experiencing an issue after updating my nodes to the latest version 1.29 and finishing the Prometheus and Grafana installation. Both my relays worked before the update but then went offline friday night and wont stay live. The Producer is also stuck at 100% sync and nodes will only stay synced for a minute or two.

CoinCashew guide (Finished, 16)
not using cntools
DigitalOcean 3 relays all (8gb / 4 intel cpu / 160 gb)

sudo systemctl status cardano-node

Journalctl -e -f -u cardano-node

I have searched the forum and tried more than a few solutions with no luck, I need help as i’m stuck! thank you for looking

You will need to increase to 10G of RAM, cancel one relay and upgrade the other 2 to 12G(I know digital ocean has high prices)… or use contabo for relays… so cheap and has 3 data centers around the world


1 Like

Thank you! How easy is it to switch the nodes to a different server provider? I am a beginner and really dont want to mess anything else up

For relay it’s easy… so you can move only the relays for the moment… but it was an option… take ur time and think about the prices

1 Like

Oh no i really like the price difference! thank you for bringing this to my attention! Is it possible you can tell me how to move the relays or send me in the right direction?

U must install the nodes, sync them and connect with the producer

Ok, Thank you. Im about to start the process i will give a status soon!

1 Like

Now… to solve the issue for the moment… for your relays… go to configuration file and set to false the TraceMempool… it will use only 4G but u will not see the tx processed anymore

ive changed both relays to false in TraceMempool and resized the producer to 16gb (the next available size). Syncing now

If u already upgraded to 16G u don’t need to set to false… go back in set to true :slight_smile:

No worries, the resize just completed and i just switched both relays back to true. Syncing now.

1 Like

Hey guys,
Sorry to start this conversation again, but after the transition of epochs, my BP node is stuck on starting and 1 relay node is starting aswell with 3/2 peers. I know it must be out of sync and tried restarting chrony.
But the relay that is working is not connecting to the BP even tho the inbound/outbound firewalls are connected, topology files are correct.

I will try restarting them after work and will troubleshoot if I can. Any help will be much appreciated. Thanks :pray:

Because the BP not started ( must be synced)

Yeah but its somehow showing 1:1 to the relay that is starting

The upgrade to the 16gb fixed the node, both producer and node are synced and running! I didnt resize and start the 2nd node as Im going to start the new nodes with contabo. @Alexd1985 you have been amazing (again) different issues same solution :slight_smile: , please let me know what i can do to show my appreciation?! Thank you again.

1 Like

Me again :joy:, I finished the node on contabo and it’s fully synced. Im getting nothing Processed TX : 0.
Screenshot from 2021-09-27 14-14-21

  1. Ive added the IP of the contabo node to the BP node(mainnet-topology)
  2. Relay node1 mainnet-topology.json has BP IP and a lot of other IP’s (do I add it here too?)
  3. checked and its not showing the contabo node.

from my previous questions im sure it something simple that Im overlooking but can you please assist??

On a side note
After you helped me with my last issue, a few days later we minted our first block!!! Thank you again!!!

1 Like

Did u restarted the BP after u added the relay IP inside the topology updater?
Did u opened in ufw (relay) the 6000 port to allow connections from any?

sudo ufw status

U need to add the line (in case u missed)
sudo ufw allow proto tcp from any to any port 6000

sudo ufw reload

Reload the BP

1 Like

I didn’t restart the BP after updating topology, if its that simple im leaving…(joking) ill do that now!

sudo ufw status BP = inactive
sudo ufw status contabo = inactive
sudo ufw status Relay1 = inactive

Ok, u will need to use the ufw for contabo servers (perhaps for the other servers u have another firewall)… before to activate the ufw add a rule for the ssh port to not lose the connection… also perform a snapshot before to activate the ufw, just in case

1 Like

After the restart of the BP the Mempool Tx/bytes are now showing but no processed. do I need to finish the other steps?

Screenshot from 2021-09-27 15-19-16