Running cardano-tools in arch architecture

I’m trying to use this docker image to use cncli for my bp node. But when I run

docker run -it --rm \
  -v ~/cardano:/var/cardano \
  nessusio/cardano-tools:dev cncli@sha256:4478cac299ada6f5cefffc6adb1b138669b46e10c9dd5a744558d3ab1a6538f5

I’m gettting
[Error] cncli not supported on this platform!. How can I fix it?


maybe this:

docker run -it --rm \
  -v ~/cardano:/var/cardano \
  nessusio/cardano-tools@sha256:4478cac299ada6f5cefffc6adb1b138669b46e10c9dd5a744558d3ab1a6538f5 cncli
1 Like

Nope. I have the same result:

interesting - linux/arm64v8 not matching with linux/arm64/v8

what is the output of

docker run -it --rm \
  -v ~/cardano:/var/cardano \
  nessusio/cardano-tools@sha256:4478cac299ada6f5cefffc6adb1b138669b46e10c9dd5a744558d3ab1a6538f5 uname -a

and on the host:
uname -a

how about this:
docker run --rm --privileged multiarch/qemu-user-static --reset -p yes
and then

docker run -it --rm \
  -v ~/cardano:/var/cardano \
  nessusio/cardano-tools@sha256:4478cac299ada6f5cefffc6adb1b138669b46e10c9dd5a744558d3ab1a6538f5 cncli

I searched for the architecture of the first docker image on picture. But in docker hub all of them are amd64

@tomdx - what do you think? I have no clue why the platform is different here…

cncli is current not supported on arm64

Andrew doesn’t provide a binary for it.

It may be possible to build from source, but so far we haven’t had anyone asking for it.

But the docker image is available for arm64 - is there any reason why - if the tool inside not working?

So I will configure cncli in order to point to my cardano pod.
There is some tutorial around there about how to do it?

I compiled from source cncli, but I don’t know how to configure it in order to connect to my bp, which is a pod of a k8s cluster. There is some doc about it?

yes - that is the usage guide:


I compiled from source cncli, but I don’t know how …

Great, I created issue #61 for that. Perhaps, we could work on this together. I could help you to get this into the nix build or you could show me how you did the build and I do the nix stuff.

But the docker image is available for arm64 - is there any reason why

Yeah, this might be a historical glitch that slipped through the cracks - we used to have the cadano-cli in that image.

Including the k8s setup and conf?

Including the k8s setup and conf?

Not sure what you mean. If this is about #61, the goal would be to have a cardano-tools image that supports the cncli leaderlog on arm64

Ok. I’m writing in the issue right now.

i run it baremetal linux on raspberry pi4 , why the container ? running multiple pods on same pi ?

1 Like

it can be a security question - if you have a container which only contains the cardano-node that would prevent host machine being hacked - but yes tipically this is not an issue