[SOLVED] Node 1.27.0 Failed to build cardano-crypto-tests-2.0.0

Trying to build the latest cardano-node 1.27.0 on:
Debian Buster 10.9.0
GHC - 8.10.4
Cabal - 3.4.0
ran cabal update
cabal configure -w /opt/ghc/bin/ghc
updated cabal.project.local

cabal build all
Starting     cardano-crypto-tests-2.0.0 (lib)
Building     cardano-crypto-tests-2.0.0 (lib)
Installing   cardano-ledger-core- (lib)
Completed    cardano-ledger-core- (lib)
Starting     ouroboros-network-framework- (lib)
Building     ouroboros-network-framework- (lib)
Installing   ouroboros-network-framework- (lib)
Completed    ouroboros-network-framework- (lib)
Starting     byron-spec-ledger- (lib)
Building     byron-spec-ledger- (lib)
Starting     shelley-spec-ledger- (lib)
Building     shelley-spec-ledger- (lib)
Installing   byron-spec-ledger- (lib)
Completed    byron-spec-ledger- (lib)
Installing   shelley-spec-ledger- (lib)
Completed    shelley-spec-ledger- (lib)
cabal: Failed to build cardano-crypto-tests-2.0.0 (which is required by
test:cardano-api-test from cardano-api-1.27.0). The build process terminated
with exit code -6

cardano-node 1.26.2 build works on the same VM just fine.

Any ideas how to troubleshoot that or what could it be?
cabal build cardano-crypto-tests-2.0.0 -v 3 doesn’t work - can’t see exact issue, if what’s going on with that failing package.

running cabal build all or

# cabal build cardano-crypto-tests
Build profile: -w ghc-8.10.4 -O1
In order, the following will be built (use -v for more details):
 - cardano-crypto-tests-2.0.0 (lib) (requires build)
Starting     cardano-crypto-tests-2.0.0 (lib)
Building     cardano-crypto-tests-2.0.0 (lib)
Installing   cardano-crypto-tests-2.0.0 (lib)
Completed    cardano-crypto-tests-2.0.0 (lib)

works fine
but initial cabal build all has failed for 3 time in a row now

SOLVED --------------------------------------------------------------------
not 100% sure but probably that was HW issue and I was running out of mem/CPU on a build node - 2CPU 4GB RAM

I don’t know if this is the issue but try to upgrade ghcup

ghcup upgrade

I saw this mentioned: Note that this release includes breaking changes to the API and CLI commands, and that compilation using GHC version 8.6.5 is no longer supported.

I’m not using ghcup, but direct packages install from official GHC debian repository. and my GHC version is noted in the original post which is 8.10.4

1 Like

So allocating more RAM/CPU resources end up fixing it? I’m having the same issue with 2 cores/4GB RAM.

Looks like “YES” … I’m 99.9% sure.

Initially I had exactly the same setup 2CPU + 4GB RAM.
Then I gave it 4CPU + 8GB RAM - did quite a few more test builds and none has failed.

Same way my dockerized build on macbook-pro has failed - unless I allowed Docker to use 12GB of RAM.

I would be surprised if you could build the node on a machine with less than 8G.

1 Like

I’m a novice here, just started.
But just before 1.27.0 release, I have build 1.26.2 several times without any problems.

Wow, good to know.

Thanks for the responses.

The size of the code base is slowly growing. That is why 4G may have been enough in the past but is no longer the case.