Stake Pool School - Error Starting Producing Node

Hi Community,
I am following the training class to build a stake pools. When I run the startup file 1. shown below to start the producing node, the error in point 2. is returned. I believe that this may be due to file “testnet-config.json” is referencing: “ByronGenesisFile”: (excerpt from the file: “testnet-byron-genesis.json”,
“ByronGenesisHash”: “96fceff972c2c06bd3bb5243c39215333be6d56aaf4823073dca31afe5038471”), instead of “testnet-shelley-genesis.json” which stipulated in the documentation and downloaded via wget.
Do I need to correct “testnet-config.json”? Or do something else to resolve?

1. I ran the following startup file
cardano-node run
–topology ~/pool/testnet-topology.json
–database-path /db
–socket-path /db/node.socket
–host-addr x.x.x.x.
–port 3000
–config ~/pool/testnet-config.json
–shelley-kes-key kes.skey
–shelley-vrf-key vrf.skey
–shelley-operational-certificate node.cert

2. Error message:
There was an error parsing the genesis file: /home/ubuntu/pool/testnet-byron-genesis.json Error: GenesisDataIOError /home/ubuntu/pool/testnet-byron-genesis.json: openBinaryFile: does not exist (No such file or directory)

Any help to resolve will be grateful. :grinning:



Inside the config.json file:

  "ByronGenesisFile": "testnet-byron-genesis.json",
  "ShelleyGenesisFile": "testnet-shelley-genesis.json",
  "ShelleyGenesisHash": "849a1764f152e1b09c89c0dfdbcbdd38d711d1fec2db5dfa0f87cf2737a0eaf4",
  "TraceBlockFetchClient": false,

you need both files placed inside the config folder.
So dowload both files from here:

Hi laplasz,
Thank you for the advice. I was able to start the node successfully using the information provided.

Much appreciated!

1 Like

No problem - actually the topic can be “closed” by marking one of the answer as solution - that can be useful if someone has similar issues