Test-ADA from the faucet fails

Hi all,
I wanted to try out MAs, but I’m stuck at step 6 of this procedure;

Yes, there are other posts about ‘the faucet’ and testnets problems, but I’d be happy to have a definite answer to;

  • Is ‘the faucet’ usable with an “… --testnet-magic XY --mary-era” address?
  • If not, any guidance to how to use own funds on the testnet would be appreciated.

Hello and welcome @Cell182,
what error message do you get?

Hello,

I am just curious, is this still valid?

Thank You

Hi adatainment,

Thanks for replying.
I get no error message at all, it’s just that the funds from the faucet don’t arrive at my address, or I can’t see them there.

Message from the faucet;
"Success
Your transaction has been successful and 1000 ADA have been sent to addr_test1vrdcesz58e2e5asc7cd7e6sf66emtsh27r8gmfc6jtlqt7gjg5gcl.
Please verify the following transaction hash:
a298f3c9faff488dc28a99dbdb6943eac2e3e0dc94a7db3c515c4f8b8c2a614b
… "

On my side it looks like this, i.e. empty;
[root@testvm mary-ppe]# cardano-cli query utxo --address addr_test1vrdcesz58e2e5asc7cd7e6sf66emtsh27r8gmfc6jtlqt7gjg5gcl --testnet-magic 3 --mary-era
TxHash TxIx Amount


[root@testvm mary-ppe]#

You do seem to have the balance on testnet network as you can see here.

You’re using the faucet used for testnet network but trying to query balance on a different network (as your command suggests --testnet-magic 3) Given that testnet network is already on Mary network, it’s probably best for you to stick to testnet network, there are not many folks using other networks.

1 Like

Hi rdlrt,

Thank you for the answer and the link, where I can see them.

Now I’m starting over, trying to be on the main testnet. What param shall be used for the main testnet (–testnet-magic 0 ?) - because it’s insisting on one;

[root@testvm ~]# cardano-cli address build --payment-verification-key-file pay.vkey --out-file pay.addr
Missing: (–mainnet | --testnet-magic NATURAL)

…yes, I’m completely new to Cardano concerning dev/test.

1 Like

I’m having the same problem. Can’t seem to get faucet Ada to my address on --testnet-magic 3. I have been following the instructions on how to create a token on testnet as per:

It explicitly calls for that testnet. Should we be using something else? If so, what do you recommend? Will we need to be running different node software as well?

Thanks for your help!

Just try this link on devnet : Native Tokens program

it should work for test ada.

1 Like

Thanks for the reply. Tried that this morning and haven’t received the Ada yet. Hopefully it shows up by tomorrow morning :slight_smile:

For testnet, you can download the files as per here.

1 Like

Unfortunately I’m still not seeing any Ada on my testnet address. Can someone send me 100 Ada on the --testnet-magic 3 network to addr_test1vqxrfpsqnw43dc0pjjv2dn4hxpahasmah322fryvpuhd4tcxplg5y
Thanks for your help!

Thank you
I’m using those config files now, but then I get these errors (maybe bc I’m on 1.25.1 and not 1.24.2?):

[root@vm mary-ppe]# cardano-cli query utxo --address $my_pay_addr --testnet-magic $tm --mary-era
Shelley command failed: query utxo Error: A query from a certain era was applied to a ledger from a different era: EraMismatch {ledgerEraName = “Byron”, otherEraName = “Mary”}

[root@vm mary-ppe]# grep -i magic ./config/*
./config/testnet-byron-genesis.json: , “protocolMagic”: 1097911063
./config/testnet-config.json: “RequiresNetworkMagic”: “RequiresMagic”,
./config/testnet-shelley-genesis.json: “networkMagic”: 1097911063,

[root@vm mary-ppe]# cardano-cli --version
cardano-cli 1.25.1 - linux-x86_64 - ghc-8.10
git rev 9a7331cce5e8bc0ea9c6bfa1c28773f4c5a7000f

All I’d like to do for now is create my own testcoin for fun, which requires a testnet where I can get some tADA from the faucet.
Should I switch to ver 1.24.2 with testnet-magic 1097911063?

Your error message just means your node is not in sync yet. It is still in Byron era , and you will need to wait until it syncs across to Mary era on testnet network

And no - please do not switch versions, 1.24.2 is not compatible.

1 Like

Thank you very much, it’s working now!

Summary of how I got the test-ADAs from the faucet to work

→ This node version: 1.25.1
→ These config files;
wget https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/testnet-config.json
plus these ones from the same URL;
testnet-shelley-genesis.json
testnet-byron-genesis.json
testnet-topology.json

→ This --testnet-magic: 1097911063
→ This faucet: Faucet
where btw the test-ADAs arrived quickly, not a 24h wait

[root@vm ~]# cardano-cli query utxo --address $my_pay_addr --testnet-magic $tm --mary-era
** TxHash TxIx Amount**
--------------------------------------------------------------------------------------
380eb4a34b0a2a2826a3b9ea62d8fbcef685ec2e19fed9c5c0b8f5aeb52460e6 0 1000000000 lovelace

Thanks to rdlrt and adatainment for the help!

1 Like

You address seems to have received ADA 4 days ago (
https://explorer.cardano-testnet.iohkdev.io/en/address?address=addr_test1vqxrfpsqnw43dc0pjjv2dn4hxpahasmah322fryvpuhd4tcxplg5y)

Are you using the right version of cardano-node (1.25.1 or above is required) ?

1 Like

Thanks for all the comments above. I read them carefully and updated my node. I was able to create a native token on Testnet :slight_smile: