Testnet stakepoll course, node not connected

Hi guys, i am trying to solve this today:

running on AWS, it looks like it doesnt connect to the node, at first it was downloading all the blocks i think, but with chainDB:Critical

probably i messed up somewhere and i cant figure it out :slight_smile:
1.
local/bin path looks weird:
echo $PATH
/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/home/ec2-user/.local/bin:/home/ec2-user/bin

it looks like i didnt setup binaries correctly or probably cant find local/bin

cp -p dist-newstyle/build/x86_64-linux/ghc-8.10.2/cardano-node-1.24.2/x/cardano-node/build/cardano-node/cardano-node ~/.local/bin/

cp: cannot stat ‘dist-newstyle/build/x86_64-linux/ghc-8.10.2/cardano-node-1.24.2/x/cardano-node/build/cardano-node/cardano-node’: No such file or directory

versions and command:

cardano-cli 1.24.2 - linux-x86_64 - ghc-8.10
git rev 400d18092ce604352cf36fe5f105b0d7c78be074

cardano-node 1.24.2 - linux-x86_64 - ghc-8.10
git rev 400d18092ce604352cf36fe5f105b0d7c78be074

cabal-install version 3.2.0.0
compiled using version 3.2.0.0 of the Cabal library

i run the node with
cardano-node run
–topology testnet-topology.json
–database-path db
–socket-path db/node.socket
–host-addr 0.0.0.0
–port 3001
–config testnet-config.json

and getting a bunch of error logs

Thanks, hope we can save this node! Cheers

hmm should i jsut start from scratch ? :slight_smile:

you can try with 1.25.1 version

cheers,

1 Like

Updating to 1.25.1 solved it. Awesome, thank you, i am learning so much and getting comfortable with commands :slight_smile:

1 Like