Third block minted? But rewards not showing? Did I lose slot battle?

not ok, rotate KES again ( cold.counter is fine) and share again

Now I get:

Screenshot 2024-02-11 at 9.54.20 PM

✓ Operational certificate's KES period is within the correct KES period interval
✓ The operational certificate counter ahead of the node protocol state counter by 1
{
    "qKesCurrentKesPeriod": 896,
    "qKesEndKesInterval": 958,
    "qKesKesKeyExpiry": "2024-05-14T21:44:51Z",
    "qKesMaxKESEvolutions": 62,
    "qKesNodeStateOperationalCertificateNumber": 0,
    "qKesOnDiskOperationalCertificateNumber": 1,
    "qKesRemainingSlotsInKesPeriod": 8005700,
    "qKesSlotsPerKesPeriod": 129600,
    "qKesStartKesInterval": 896
}

I was talking with some other members and apparently the disk recognizes the new cert but the node doesn’t for some reason and is still showing 0, why is this?

Now it should be fine, wait for the next block

Isn’t this the condition it was in my original post when it missed the minted block though? I’m trying to understand what is different? I’m just really scared I’m going to miss another minted block because I don’t understand what is different now vs the original first post

could be more reasons: wrong KES, peers, etc

now, lets see why you don’t have tx incrementing… who is your IN peer? is your relay?
IN case yes, share the glive output for your Relay

Yes I have two relays, I noticed they are not sending transactions as well so restarted the servers for them and waiting to see if that fixes anything.


so I waited a bit for them to restart here is the screenshot for…

relay #1

relay#1

relay #2

relay#2

bp

Screenshot 2024-02-12 at 4.08.10 AM

Note, that in the original first post there was transactions occurring and it still didn’t work. That said I acknowledge this is ‘another’ issue that needs to be resolved as well! So thanks for pointing that out. Not sure why there is no transactions coming in?

My config files in case you want to see dates they were modified is here:

Screenshot 2024-02-12 at 4.19.27 AM

I should be using the latest versions for 8.7.3, ONLY mainnet_config.json and conway-genesis.json changed from my understanding.

As for the firewall, nothing has changed on that front from how it was working before.

UPDATE -----

I just noticed that the topology files are different for 8.7.3, so I changed mine to this

{
   "localRoots":[
      {
         "accessPoints":[
            {
               "address":"ip ommited",
               "port":6000
            },
            {
               "address":"ip ommited",
               "port":6000
            }
         ],
         "advertise":true,
         "valency":2
      }
   ],
   "publicRoots": [
    {
      "accessPoints": [
        {
          "address": "backbone.cardano-mainnet.iohk.io",
          "port": 3001
        },
        {
          "address": "backbone.cardano.iog.io",
          "port": 3001
        },
        {
          "address": "backbone.mainnet.emurgornd.com",
          "port": 3001
        }
      ],
      "advertise": false
    }
  ],
  "useLedgerAfterSlot": 110332824
}

Apparently they changed the public roots default access points? Restarting the relays to see if this fixes the transactions issue.

I will suggest you to keep the BP and relay 1 in p2p mode disable and only relay2 in p2p enabled. I don’t know how p2p its working or if its working as it should.

How do I disable p2p for one of the relays? and also for the bp node, also note that I didn’t have my topology file updated with newest relay information apparently for 8.7.3, so maybe this will fix the transaction issue?

then, fix this and lets see after…

Fixed it, but still same issue with no transactions unfortunately, even after multiple restarts
Screenshot 2024-02-12 at 8.26.26 AM

check inside configuration file, did u set TraceMempool to true?

Cheers,

@Alexd1985 It’s set to false currently, should it be true? I’m setting to true for now to test. (in retrospect editing this post later, apparently it’s better to have it be false? should I change it back to false, very confused)

My entire config file is below (with traceMemPool set to true now):

{
  "AlonzoGenesisFile": "alonzo-genesis.json",
  "AlonzoGenesisHash": "7e94a15f55d1e82d10f09203fa1d40f8eede58fd8066542cf6566008068ed874",
  "ByronGenesisFile": "byron-genesis.json",
  "ByronGenesisHash": "5f20df933584822601f9e3f8c024eb5eb252fe8cefb24d1317dc3d432e940ebb",
  "ConwayGenesisFile": "conway-genesis.json",
  "ConwayGenesisHash": "f7d46bdd3b3c8caf38351c4eef3346a89241707270be0d6106e8a407db294cc6",
  "EnableP2P": true,
  "LastKnownBlockVersion-Alt": 0,
  "LastKnownBlockVersion-Major": 3,
  "LastKnownBlockVersion-Minor": 0,
  "MaxKnownMajorProtocolVersion": 2,
  "Protocol": "Cardano",
  "RequiresNetworkMagic": "RequiresNoMagic",
  "ShelleyGenesisFile": "shelley-genesis.json",
  "ShelleyGenesisHash": "1a3be38bcbb7911969283716ad7aa550250226b76a61fc51cc9a9a35d9276d81",
  "TargetNumberOfActivePeers": 20,
  "TargetNumberOfEstablishedPeers": 50,
  "TargetNumberOfKnownPeers": 100,
  "TargetNumberOfRootPeers": 100,
  "TraceAcceptPolicy": true,
  "TraceBlockFetchClient": false,
  "TraceBlockFetchDecisions": false,
  "TraceBlockFetchProtocol": false,
  "TraceBlockFetchProtocolSerialised": false,
  "TraceBlockFetchServer": false,
  "TraceChainDb": true,
  "TraceChainSyncBlockServer": false,
  "TraceChainSyncClient": false,
  "TraceChainSyncHeaderServer": false,
  "TraceChainSyncProtocol": false,
  "TraceConnectionManager": true,
  "TraceDNSResolver": true,
  "TraceDNSSubscription": true,
  "TraceDiffusionInitialization": true,
  "TraceErrorPolicy": true,
  "TraceForge": true,
  "TraceHandshake": true,
  "TraceInboundGovernor": true,
  "TraceIpSubscription": true,
  "TraceLedgerPeers": true,
  "TraceLocalChainSyncProtocol": false,
  "TraceLocalConnectionManager": true,
  "TraceLocalErrorPolicy": true,
  "TraceLocalHandshake": true,
  "TraceLocalRootPeers": true,
  "TraceLocalTxSubmissionProtocol": false,
  "TraceLocalTxSubmissionServer": false,
  "TraceMempool": true,
  "TraceMux": false,
  "TracePeerSelection": true,
  "TracePeerSelectionActions": true,
  "TracePublicRootPeers": true,
  "TraceServer": true,
  "TraceTxInbound": false,
  "TraceTxOutbound": false,
  "TraceTxSubmissionProtocol": false,
  "TracingVerbosity": "NormalVerbosity",
  "TurnOnLogMetrics": true,
  "TurnOnLogging": true,
  "defaultBackends": [
    "KatipBK"
  ],
  "defaultScribes": [
    [
      "StdoutSK",
      "stdout"
    ]
  ],
  "hasEKG": 12788,
  "hasPrometheus": [
    "127.0.0.1",
    12798
  ],
  "minSeverity": "Info",
"options": {
    "mapBackends": {
      "cardano.node.metrics": [
        "EKGViewBK"
      ],
      "cardano.node.resources": [
        "EKGViewBK"
      ]
    },
    "mapSubtrace": {
      "cardano.node.metrics": {
        "subtrace": "Neutral"
      }
    }
  },
  "rotation": {
    "rpKeepFilesNum": 10,
    "rpLogLimitBytes": 5000000,
    "rpMaxAgeHours": 24
  },
  "setupBackends": [
    "KatipBK"
  ],
  "setupScribes": [
    {
      "scFormat": "ScText",
      "scKind": "StdoutSK",
      "scName": "stdout",
      "scRotation": null
    }
  ]

I am restarting all the servers with these settings again. I noticed this

“TraceTxInbound”: false,
“TraceTxOutbound”: false,

should those be true? I don’t ever remember setting this stuff but maybe when I upfdated to 8.7.3 it got overwritten, what is your config set to?

it needs to be set to true in order to see tx transactions… but your node/server must have more than 16G RAM

1 Like

relay1
relay2
bp

Ok that fixed the transaction issue, now is just the concern that the node does not show ‘1’ also, how do I fix that?

UPDATE–

So I talked with one of the devs of the glliveview tool and he said…

details have changed slightly…before CLI used to report state of node, now CLI reports the state of chain (so second and third column is essentially giving same values)

So now - the behaviour is:

Initial State before you rotate:

Disk: 0

Node: 0

Chain: 0

State post you rotate:

Disk: 1

Node: 0

Chain: 0

State post you restart your node:

Disk: 1

Node: 0

Chain: 0

State post you mint a block with new opcert:

Disk: 1

Node: 1

Chain: 1

Maybe this might help someone else out also.

In other words what I have is apparently okay, he thinks I just didn’t have enough relay nodes to propagate the block at that time. Curious your thoughts on this @Alexd1985 ?

Okay so I am scheduled to mint a block on this day

2024-02-23

I really hope everything is setup correctly this time from the screenshots? Does it look good to you still @Alexd1985

I made blocks with only 1 relay so… its not the case… anyway if this was the case you should see the blocks as stolen on pooltool

it looks ok. could be something else… cncli db corrupted and in this case it will show fake blocks asigned

1 Like