Understanding gLiveView Block Producing Metrics - an explanation to a basic question sought!



1 Like

@Karlaz the best resource for SPO is here: Guild Operators Documentation although prior reading is necessary to understand what each step is doing… Make sure you read every page (I missed the CNCCLI section).

Thanks everyone, will take me some time to read and understand everything because I am also very new to Linux. This opportunity I am not going to miss because I think it can help me to make world better place. I think this is exactly what is purpose of ADA and whole cardano blockchain.


Check the producer, relay for tx processing for IN/OUT peer and also I will recommand to install chrony

OK great and thanks for the tip!

1 Like

Next time prevent showing your bp’s ip address.


@Alexd1985 Is there any need in keeping the pledge wallet keys on the BP node? Note I initially set this up using the mnemonic approach (using a Daedalus wallet), and have since deleted the wallet and keys for security reasons.

1 Like

It’s ok as long u wave the seed words

1 Like

Yes of course - and thanks again mate :+1:

1 Like

@Alexd1985 would you be kind enough to help out with this (a bit devastated):

  • Missed : Scheduled at slot but no record of it in cncli DB and no other pool has made a block for this slot

As far as I can see the BP and Relays were fine over this period. Noting, I did not get around to installing Chrony.

Hmm, TBH I don’t know why this happened (but I know it can happens sometimes); your pool is ok from all points of view…
Could be related with parent slot but u can check (if u know the slot leader number) in to the logs…

Also can be an error from cncli, I also found this on an old post:
“ Hello everyone -

I am excited to announce that this morning my pool DID mint a block. The issue, although I am unsure why, is that CNCLI was calculating the wrong epoch nonce when running the leaderlogs which was producing an incorrect leader schedule. I discovered this when I built a new block producing node over the weekend and when I ran cncli for the first time on that node it returned a different Nonce value and indicated that we had not yet ever missed any blocks.

I would like to know more about how nonce is determined to avoid this in the future, but for now I am happy that things appear to be working!”

U can reinstall cncli and run again the cncli leaderlog… but this time run ./cncli.sh leaderlog force (to force it to recalculate for epoch 256)


Hi and thanks for your reply. Yes - I’ve been reading those, and can see others are also experiencing these types of issues. It makes sense that if cncli is incorrectly reporting a scheduled block, it would appear as missed.

However it does seem a bit weird… and understandably, I’m interested in simply validating my setup (noting that at the moment we have a comparatively small delegation (250k). All relays seem fine, connected to peers (20 out / 7 in). The BP is processing tx’s as are the relays, and the KES certs are valid (just rotated and restarted to be sure).

I will reinstall CNCLI, and see how we go in future epochs.

Are there any logs that you aware of that i can check for further troubleshooting?

Thanks Alex.

If u know the exact time and the slot number u must find logs about the slot inside logs folder

1 Like

Yeah… u need to calculate the time from cncli slot in ur server time… and check in the right folder… if u can find anything about the slot then it means it is a false information…I think

Nope, no any clue

1 Like

@Alexd1985 thanks so much for your help with this (and sorry for being a pest). It seems the CNCLI was a fair explanation! We couldn’t be more excited to produce this block, and officially be part of the SPO community! Appreciate your help and assistance immensely mate :beers:

1 Like

you are welcome, anytime!

also, can u delete the username/hostname of your producer from above message?

Thank you

As an FYI, Leader incremented, image . I literally restarted the node, just before the block was minted, so this might also be coincidence.

1 Like

done and thanks

1 Like

Hello, my CNCLI script is running on version 1.0 and when i run the scripts, it asking for updare, would you please guide me how can i upgrade the cncli script only?