Wallet fails to connect to node on preview/preprod with new node and wallet versions

I’m trying to integrate Cardano into my platform but the wallet is unable to connect to the node (running in the same docker image). I use node version 1.35.3 and wallet version v2022-10-06. After a while, the node gets the expected “Chain extended” and I can query it using the cli. I run the node using the following command:

cardano-node run 
--topology /data/$NETWORK_NAME-config/topology.json 
--database-path /data/db/ 
--port 3001 
--config /data/$NETWORK_NAME-config/config.json

where the $NETWORK_NAME is either preprod or preview, a volume is mounted on the /data path and configs are downloaded from https://book.world.dev.cardano.org/environments/$NETWORK_NAME/<config_type>.json.
Now to start the wallet server I check for the existence of the nodes socket using a bash script, after which I run the following command:

cardano-wallet serve 
--port 8090 
--testnet /data/$NETWORK_NAME-config/byron-genesis.json
--database /data/$NETWORK_NAME/wallet-db 
--token-metadata-server https://metadata.cardano-testnet.iohkdev.io

The initial messages seem to suggest that the wallet is connecting to the right network but when connecting to the node it gives the following message:
“Node connection lost because of the mux error” followed by a repeated Couldn’t connect to node error and repetitions of the previous error.

Is anyone having similar issues with these versions/configs or am I missing something in my configuration? Any help is appreciated!

1 Like

I also have the same problem, have you found a solution?