WARN: No pools available that can be selected! Required files: cold.vkey cold.skey vrf.vkey

I’m seeing
WARN: No pools available that can be selected! Required files:
when trying to modify my pool using cntools.
But the files are there. permissions 755. I even moved my cold keys over to see if going in online mode would accomplish something.
I think my key cold counter may have gotten out of sync or something?
Is there a safe way I can re-generate all my other keys from my offline node without having to deposit another 500 ada registration?
I’ve got tons of backups of the files, but none of them seem to work.
Please help. I feel like I’m about to vomit.

the files are encrypted (gpg extension) ?

can u show the ls -l output for pool folder?


I unencrypted the files (none of them are .gpg).

-rwxrwxrwx 1 user user 203 Apr 19 02:36 cold.counter
-rwxrwxrwx 1 user user 187 Apr 19 02:34 cold.skey
-rwxrwxrwx 1 user user 197 Apr 19 02:34 cold.vkey
-rwxrwxrwx 1 user user 1327 Apr 19 02:36 hot.skey
-rwxrwxrwx 1 user user 183 Apr 19 02:36 hot.vkey
-rwxrwxrwx 1 user user 4 Apr 19 02:36 kes.start
-rwxrwxrwx 1 user user 365 Apr 19 02:36 op.cert
-rwxrwxrwx 1 user user 57 Apr 19 02:34 pool.id
-rwxrwxrwx 1 user user 57 Apr 19 02:34 pool.id-bech32
-rwxrwxrwx 1 user user 230 Apr 19 02:34 vrf.skey
-rwxrwxrwx 1 user user 176 Apr 19 02:34 vrf.vkey

Thanks for the quick response!

u are missing
pool.config file
poolmeta.json → not mandatory

do those normally reside in the same folder? can they be regenerated without re-paying the key deposit? I don’t see them anywhere. But this WAS working at some point yesterday, because I modified the pool already. (chasing issues I found using pool.vet - Cardano stake pool checker)

edit: I have op.cert, are there 2 cert files?

Yes, they should be reside in same pool folder

If yesterday it worked then propably u deleted also another files?

unfortunately I think you must be right.
Can these files be regenerated?

But… u can’t find them somewhere in ur old bkp? U didn’t bkp the all priv folder never?

it looks like I only backed up the cold/offline node.

i checked and pool.cert is the stake pool registration certificate

Does that mean I’m screwed?

Nope… it can be fixed

But check if u can find it first

OMG it was sitting in the trash. which is bizarre because I’ve been working in command line this whole time…

THAT FIXED IT! @Alexd1985 you are the best, man! I still feel like I’m going to throw up but at least I’m not out 500A! Now to get these cold keys off my node… and make sure I back EVERYTHING up. twice.

1 Like

Great! U must delete only cold keys from pool folder and 2 files from wallet payment.skey and stake.skey

Those file should not be on server

But also everytime when u will change something check which files were changed and bkp all of them

1 Like

I’m just going to back up the entire /opt folder this time. no more taking chances!

Exactly… bkp all priv folder

1 Like

Cold keys are important to not loss for pool
and those above files for wallet

1 Like

one more question: which keys should I not leave on my node?
cold.skey, obviously.

…any others?

U can delete all, u will need only for node to run as a producer:

  • –shelley-kes-key kes.skey \
  • –shelley-vrf-key vrf.skey \
  • –shelley-operational-certificate node.cert
1 Like