Withdraw transaction from stake address not showing

Hello dear cardano community,

I’m new here and must say I was really too much enthusiastic when I started to create my own stake pool some weeks ago.
When I realized I will never make even a single lovelace from my small pledge, I decided to retire my stake pool. Everything went fine so far.

Yesterday I wanted to withdraw the ADA from my stake pool’s addresses and to send to my daedalus wallet.
The idea I had was to send all ADA from pool payment and stake rewards addresses in one transaction (in the payment address I have 2 different transactions to use)

I submitted the transaction successfully but nothing happened.
This is the raw transaction build (it was signed after, and submitted)
cardano-cli transaction build-raw
–tx-in 184ace83d236c1ff8ed58c5565ea8118e699f7872dcb426f3edbbad95ee7ac74#0
–tx-in 234ca4fe556da6eb3201953bc9255c507e350f1455078399f06aff56bc3cccf2#0
–tx-out addr1q9f3ll0gztrmaq7nzpg5s34a8fz368gvjmm47hrhhqp0ftfsf2hqzpfp2u9vsutdjsa99a7wr7g8n9s7wmem7mexl7mqkkcvtt+1019516717
–withdrawal $(cat temp/stake.addr)+500000000
–invalid-hereafter 26533830
–fee 180021
–out-file withdraw_rewards.raw

When I realized that nothing happened, about one hour later, I tried to build another transaction just to withdraw to the payment address
cardano-cli transaction build-raw
–tx-in 184ace83d236c1ff8ed58c5565ea8118e699f7872dcb426f3edbbad95ee7ac74#0
–tx-out (cat temp/payment.addr)+501276689 \ --withdrawal (cat temp/stake.addr)+500000000
–invalid-hereafter 26583277
–fee 178437
–out-file withdraw_rewards.raw

Same result again, the transaction was successfully submitted, but nothing happened.

So I don’t where to go to see what is wrong, any suggestion ?

Thanks a lot !

What is ur ticker?

Hello Alex
My ticker was PRPDA (stake1u945d26xej4dps4vdh9y84ek44vd242um4ftq7jxnzy69dq3ph95k)

Ok, u received 500 ADA back as a reward

so, u will need to withdraw the rewards first
And after create a simple transaction to send the funds to daedalus

U can find all the steps here (withdraw rewards and create a simple transaction)


ok thanks Alex, I will review it again, and let you know.

1 Like

But the node should be synced when u create the transactions.

Humm … Maybe there’s something wrong here. My relay node is quite short of memory and has some swap on … and I can see that the last slot processed (chain extended) [kamino:cardano.node.ChainDB:Notice:2021] [2021-04-17 07:44:23.07 UTC] Chain extended, new tip: c54bd6bad96174f07aa47a04791812a3f27d8c3ae1144e7075a114c81a6f70cd at slot 27043260

while the current one on cardano explorer website is about 27079207

so my node seems a bit too much behind … Like struggling to recover the full blockchain.
Would it be causing my transaction issue ?

One (stupid?) idea that is coming up : may I use another cardano node to submit the signed transaction ? Like the node run by Daedalus ? (which is on a much powerful desktop PC)

Yes, the node should be synced and also u can try on another node as long u upload the files but should be a cardano node cli based

1 Like

Okay that was clearly the issue. Created successfully my transaction with Deadalus cardano-node, with cardano-cli client
I was confused because I was able to create transactions with the faulty node before.

Problem : unable to see transaction in the blockchain, despite “transaction successfully submitted” message
Cause: cardano node was having issues to keep in sync with the blockchain, due to memory issues (too much swap probably)
Solution: used another node without any sync issues to submit the transaction (in my case used the transaction signed file to submit transaction with cardano node used by Deadalus, by using cardano-cli tool)

Thanks Alex for highlighting that sync issue.

You are welcome!

1 Like