Pool deposit missing after retiring pool

I created a pool on 1/16/2021, but even after many epochs, the pool never showed up on adapools, so I gave up and decided to retire it. Now I am not sure if I retired it properly and how to go about getting the 500 ADA pool deposit back. My Pool ID is:
19baf409a231aa295a81fab2a7d72e9b2f3b8605acbad0e427f22368

adapools shows it as (retired, but I haven’t seen my 500 ADA pool deposit returned to either my payment address or my stake address. I have seen somewhere that it will be returned to the “reward” address, but I don’t have one of those, just stake and payment. When I check the balance on my payment addr, it shows 2.4 ADA, which is what I left in there out of the 505 ADA I initially transferred. When I check the stake addr balance the CLI says invalid address, so I don’t know what happened there. Can anyone give me any hints on how to track down the deposit? Thanks in advance!

Here is the transaction ID:
e8f22dd096d134c5e51ce9d27e41e268245ceaf9a1ba64fa4767816e8fef9401

payment.addr:
addr1qydd9z429jvm40h8kzpvkmgvvcdn0feyvmvef7xpfh5ahzkkpw2dnr9euuv5zfygczhqhx86x7xx0urjdq2vgwx8fazs678mty

stake.addr:
stake1u8tqh9xe3ju7wx2pyjyvptstnrar0rr87pexs9xy8rr573gjxaw2d

U will need to wait 2 epochs

I double checked and it seems u need to withdraw them (like rewards)

image
Cheers,

2 Likes

Thanks @Alexd1985. I didn’t know I had to manually collect the rewards. I followed this guide and when I sent the transaction I got no response from the command line, which is usually a good sign, but I haven’t seen any change in my balance yet.

But when u type this command, do u see the reward?

cardano-cli query stake-address-info
–mainnet
–address $(cat stake.addr)

Thanks @alexd1985 for your continued help. I have to add the “–mary-era” option to get the command to but, but yes, I do see the reward there:

bosr@blockProd:~/cardano-my-node$ cardano-cli query stake-address-info --mary-era --mainnet --address $(cat stake.addr)
[
{
“address”: “stake1u8tqh9xe3ju7wx2pyjyvptstnrar0rr87pexs9xy8rr573gjxaw2d”,
“delegation”: null,
“rewardAccountBalance”: 500000000
}
]

I thought the withdrawal transaction would move that balance from the stake1… address to my payment address. It has been overnight since I ran the transaction, so I guess it didn’t go through. If I try running the transaction again, I get this error message:

Shelley command failed: transaction submit Error: Error while submitting tx: ApplyTxError [LedgerFailure (DelegsFailure (WithdrawalsNotInRewardsDELEGS (fromList [(RewardAcnt {getRwdNetwork = Mainnet, getRwdCred = KeyHashObj (KeyHash “d60b94d98cb9e719412488c0ae0b98fa378c67f0726814c438c74f45”)},Coin 500000000)]))),LedgerFailure (UtxowFailure (UtxoFailure (BadInputsUTxO (fromList [TxInCompact (TxId {_unTxId = “379fc762ee342af0f0a20618cf5c1569539927cb54eabd5026aa8e9d4a3ab5fa”}) 0])))),LedgerFailure (UtxowFailure (UtxoFailure (ValueNotConservedUTxO (Value 500000000 (fromList )) (Value 502445989 (fromList )))))]

I don’t understand why it says “Shelley command failed” because I am trying to run a Mary transaction, as shown in my signed file (shown truncated):

{
“type”: “Tx MaryEra”,
“description”: “”,
“cborHex”: "83a500…>
}

Also, if this is my payment address balance:

bosr@blockProd:~/cardano-my-node$ cardano-cli query utxo --mary-era --mainnet --address $(cat payment.addr)
TxHash TxIx Amount

Other topics for thid error

https://forum.cardano.org/search?q=ValueNotConservedUTxO

Happy Easter to everyone. This is still not working for me. This morning I tried again to send a withdraw transaction and again I received no error message from the command line, so I assume the transaction went through, but nothing changed. My reward balance is still 500000000 (500 ADA) and my payment address is unchanged. After waiting a few minutes, I tried a second transaction with a smaller amount (300 ADA) and I got the “ValueNotConservedUTxO” error (please see below). I think that is because maybe I have a transaction pending? Why does the CLI not give the user a transaction ID so I have something to check the explorer with? Is there any way to turn on debugging so I can figure out what is going wrong???

Shelley command failed: transaction submit Error: Error while submitting tx: ApplyTxError [LedgerFailure (DelegsFailure (WithdrawalsNotInRewardsDELEGS (fromList [(RewardAcnt {getRwdNetwork = Mainnet, getRwdCred = KeyHashObj (KeyHash “d60b94d98cb9e719412488c0ae0b98fa378c67f0726814c438c74f45”)},Coin 300000000)]))),LedgerFailure (UtxowFailure (UtxoFailure (BadInputsUTxO (fromList [TxInCompact (TxId {_unTxId = “379fc762ee342af0f0a20618cf5c1569539927cb54eabd5026aa8e9d4a3ab5fa”}) 0])))),LedgerFailure (UtxowFailure (UtxoFailure (ValueNotConservedUTxO (Value 300000000 (fromList )) (Value 302445989 (fromList )))))]

Below are the exact commands I used in case anyone can spot anything that doesn’t look correct:

cardano-cli transaction build-raw --mary-era
–tx-in 379fc762ee342af0f0a20618cf5c1569539927cb54eabd5026aa8e9d4a3ab5fa#0
–tx-out (cat payment.addr)+0 --withdrawal (cat stake.addr)+0
–invalid-hereafter 0 --fee 0 --out-file withdraw_rewards.draft

cardano-cli transaction calculate-min-fee
–tx-body-file withdraw_rewards.draft
–tx-in-count 1
–tx-out-count 1
–witness-count 2
–byron-witness-count 0
–mainnet
–protocol-params-file params.json

expr 2445989 - 178437 + 500000000
502267552

currentSlot=$(cardano-cli query tip --mainnet | jq -r ‘.slotNo’)
echo Current Slot: $currentSlot

cardano-cli transaction build-raw --mary-era
–tx-in 379fc762ee342af0f0a20618cf5c1569539927cb54eabd5026aa8e9d4a3ab5fa#0
–tx-out (cat payment.addr)+502267552 \ --withdrawal (cat stake.addr)+500000000
–invalid-hereafter 23068968
–fee 178437
–out-file withdraw_rewards.raw

cardano-cli transaction sign
–tx-body-file withdraw_rewards.raw --signing-key-file payment.skey
–signing-key-file stake.skey --mainnet --out-file withdraw_rewards.signed

cardano-cli transaction submit --tx-file withdraw_rewards.signed --mainnet

Have you been able to get your funds out?

Thanks for asking. I did eventually get it to work. My node was not syncing, do I had to use a new node to submit the transaction. Still learning. :slight_smile:

Hello, one question from me, I also want to retire the pool, and i’d like to ask whether the deposit is return by itself to my wallet, or do i need to claim manually from reward, as claim reward??

Yes, u will need to claim manually from reward

hello, but thanks Alex, but after i try to claim my reward from this link tutorial Guide: How to build a Cardano Stake Pool - CoinCashew
the error arise, it said that there is not TX-IN, and my balance become 0,
Yet my reward (stake address) is correct, 500,000,000

In addition to my comment,
I think the problem is because i sent the other wallet in yoroi to my payment address wallet which makes not sync?? And return 0 wallet,
I used to sent from exchange to my payment address but its still working, but why if I sent ADA to my payment address from yoroi (other wallet) will raise an issue (TX-IN). Do you have any suggestions, beside sending back to my yoroi wallet? because. Currently, I sent my payment address wallet into exchange wallet (binance) that may be complicate the issue.

It is not automatic, you have to manually claim it as a reward and then send it to your wallet.

The node should be synced in order to retrieve the reward… now question… when u created the pool did u imported the wallet via seed words? And after that did u performed transactions from yoroi,

Cheers,

I solved the issue for the most part. My pool was not synced, which caused the initial problem. I didn’t know this because the grafana dashboard wasn’t working because I didn’t have the latest version of the cli. I didn’t want to mess with that machine, so I fired up a new node, waited for it to sync, and collected my rewards. Transferring them to my wallet was another issue. I kept getting UTxO errors trying to send all at once. I had to break it up into a few smaller transactions. I got my 500 ADA back, but I stranded about 1.4 ADA in my payment address. Can’t get any more transactions to work with such a small amount of ADA. Oh well, cost of education about Cardano UTxO. Thanks for your help @alexd1985.

Hi guys. I’ve a similar bad experience. I dereg my pool and my stake address in the same time. Unfortunately I was not aware of my deposit going to my stake address. I thought it was like deposit… going back to my payment address. Anyway, I reg my stake address again but it’s empty, no reward nor my deposit. Do you know how to reclaim them?

Here are my info:
stake1u8g7w4y5qkrk3n74ysnvwuqylsvj52gscj287y7tt3kyx7q7peqmd
Tx: https://explorer.cardano.org/en/transaction?id=a081b4ca1f467fca0bc5fae8e82e0c3a550637cf3e2a161448afa9d2a848ed22

Thanks

What is the ticker?

MCMC it has been retired epoch 260 I think.

Ok, I think u should receive the 500 ADA back as a reward in the same wallet from were ADA have been sent