Yoroi wallet stuck

Today I made several transfers from my Yoroi wallet towards several addresses.

The first transfers worked just fine, as usual.

Then, a very strange thing happened: One of the transfers got stuck as “pending” but the previous transfer cleared out ok and there actually is a posterior transfer (to the pending one) that cleared out just fine, too.

I now have a pending transfer sandwiched between two cleared out transfers and my ADA funds are stuck there as I get an error message of “Cannot send a new transaction while an existing one is still pending.”, but it has been pending for 3 hours already and usually the transfers take minutes.

It looks like a bug.

Anyone has had this same issue and can suggest a way of solving it? I am actually in a hurry to clear those transfers and my ADA funds are stuck while the pending transaction doesn’t go through, and it looks as it might actually never go through…

This problem is present in Firefox and Chrome as well. I am using windows 10.

Any help appreciated, thank you.

Hi Godio,

@SebastienGllmt Can clear this for you by manually telling the node this is a failed transaction. However he will need your Transaction ID. If you send it to him or myself, I can pass it on. Then hopefully by the time he reads this, he will be able to help you.

1 Like

Hey Luke! Thanks for your help.

I DMed you the transaction details.

Also DMed @SebastienGllmt about it.

Thanks for the tip

1 Like

SOLVED with the kind help of Ambassador @Lgbeano and dev @SebastienGllmt. A BIG THANKS for both of them.

Apparently Transactions getting stuck pending forever is a known issue with Cardano-SL so there’s not much we can do about it other than wait for either Ouroboros BFT or Shelley to fix this.

If you ever get stuck on a eternally pending transaction, the only way out is to manually fix the node by changing the status of “pending” to “failed”. Once the transaction shows as failed, you can keep on sending ADA and using your wallet as usual.

Only a dev can solve this manually, so your best bet is to contact a dev: Don’t forget to mention the transaction ID. Sebastien Glimt solved it for me.

Anyway, don’t freak out about this issue as it will be fixed in the next upgrades (either Shelley or Ouroboros) and it seems to be a relatively rare problem. I have done hundreds of transactions with the Yoroi wallet and this is the first time I encountered this issue.

I wish you all great ADA transactions!