Activate P2P on mainnet

hi guys good morning, i’m going on mainnet with my pool, i’m setup my BP on 1.35.5 my first relay on 1.35.5 and my second on 1.35.7

on my second relay i want activate the p2p connection
but i can’t find the value on my config.json file

when i run my stake pool on preprod i have the option on the config.json file… but how can you see there no option for P2P…
i’m missing something? thanks for any hint

screen of preprod config.json

You need to add the option, it is not there by default.
"EnableP2P": true,
An don;t forget to change your topology file to the format required by p2p.
You should upgrade all nodes to 1.35.7, because the older versions connecting to a p2p node have some issues.

1 Like

oh okay i need to add manually and no problem with topology format, thanks for reply :pray: :grin: