ADA coins stuck on broken APP

Hey all, has anyone used SignKeysPro to hold ADA and now can’t get the coins out? I’m stuck, the app says error connecting to server and nothing works :weary: it looks like the company is gone ! Someone from BSC groups said they were able to retrieve their coins by doing some manual procedure … but that is on BSC any help or idea would be appreciated.

Ive never heard of SignKeysPro to be fair, but if the company is gone and you are not in possession of your keys/seedphrase, i think there is no chance to get them back.

I also have never heard of that app, but I just did install it and it also completely “connecting to server” errors out for me. The website of the company is still there, but that doesn’t need to mean anything.

What I could see is that it uses 12 word seed phrases. If you are very lucky, they really stored your funds on the Cardano chain and used the standard way of deriving keys from the seed phrase. In that case restoring with your seed phrase on, e.g., could give you access to your wallet.

If that only gets you to an empty wallet, they use a different system. Another system that I know that uses 12 words is the one of Could also be worth a try.

1 Like

I do I have the seed phrase. I have the transaction hash and the wallet from SignKeysPro is the receiving address from the last transaction showing the exact amount of ADA I have.

We can’t see more than you from that screenshot.

Have you tried to restore the seed phrase in one of the usual Cardano wallet apps? As said, allows 12 word phrases, but also has them. Maybe also others:

If that doesn’t work, have you tried Exodus? I wouldn’t recommend it precisely because it doesn’t use the same standards as all the other Cardano wallets, but if it can access them, you can at least use it to transfer out.

Can you link the manual procedure that worked for BSC? Maybe, we can see from that what might work on Cardano.