All set up, but relay uncontactable?

Dear all,

I’ve managed to set up a pool on the mainnet, finally! Everything seems to be ok (based on the manual), but there are a few questions open:

  1. - relay uncontactable. What is wrong here?

  2. user@srv:~/cardano-my-node$ cardano-cli query stake-snapshot --stake-pool-id $(cat stakepoolid.txt) --mainnet
    “poolStakeGo”: 0,
    “activeStakeGo”: 23857504839454979,
    “poolStakeMark”: 0,
    “activeStakeMark”: 23849267970809683,
    “poolStakeSet”: 0,
    “activeStakeSet”: 23848572589189307
    Is this right?

  3. Grafana dashboard shows no activity… (top two graphs, whereas on my testpool this was quite busy)

  4. how can I double check that all is well? Can I somehow see or run a test that all is good?

Thank you very much!

what is the ticker? And also share the glive output

u can check the pool on
for Q1 check if for relay u opened the port to accept connections from any

Hi Alex,Ticker is Cul0. I linked to the pool on adatools.
The gLiveview looks good.

Hmm, I opened the port for the BPN only… could that be it?

Is this the relay output?
How much RAM have the servers?

Yes, this is the relay.

I took the minimum stake pool reqs until I made some results.

CPU 4x2.66Ghz

✓ RAM 12288MB

✓ RAID-10 hdd 300GB

✓ Port 1 Gbps

✓ Bandwidth Unlimited

Ok, so let’s start :slight_smile:

  • u have only 1 IN peers (the producer) - that’s why u don’t have tx processed (and no data on grafana)
  • to fix this for relay open the port 6001 to accept connections from any (I just checked it and it’s closed); also check if on configuration file do u have TraceMempool set to true - if not set it to true and restart the node (u will still see no tx processed til other nodes will connect to relay)
  • the topology updater must run 1/hour


1 Like

Thank you so much, again, Alex.

Yes, 1 peer in, the BP - which does not process? Why is that?
But 22 peers out. I thought that it was ok because of that.
When you posted your previous answer, I immediately opened the port for all. So your check must have been just before that. Right now Adatools shows that it is contactable! TNX!

TraceMempool was true already.

Do I also need to open a couple of different ports to connect to others that use those ports? Say 3001 or so? [not using it myself, but looking at other pools, some use it]
Topology updater runs with the crontab as indicated. I tried to run it manually again, but it complained that it runs 1/h - so that should be good.

With ufw rules u are controlling the incoming connections only … for out connections u don’t must to have ports opened

U will not process any tx because not having any other node connected as IN peer u will not receive transactions from the network

Ok, how do I fix that then? That is what the topologyupdater is for, right?

Yes, check the logs for topology updater… once u see the message : “glade u are staying with us!” should be fine… after a while u will see another nodes connected

It worked! It was the port… thanks

1 Like