Anyone using Daedalus wallet on Ubuntu?


Anyone using Daedalus wallet on Ubuntu. I am not a developer and have no knowledge of coding either. So, this question might sound stupid, but I tried installing linux version on ubuntu with no success. After searching here, I found that there might be no version available for ubuntu till date.

Just hoping if someone here installed it on ubuntu somehow? If not, which is the safest alternative wallet?


1 Like

You could use the Yoroi extension on Chrome, Brave or Firefox browsers.


Thanks for the reply Rob.
My ADA is still on the exchange. Most of the videos and reddit posts are about transferring cardano from Daedalus to Yoroi. So, is it possible to transfer ADA from exchanges directly to Yoroi?


I was able to download, install and run Daedalus on Ubuntu 18.04.
What exactly was the problem you ran into?
Shawn - Squid Pool

1 Like

Yes you can send to Yoroi wallet from Exchange directly.
And sure - there isnt a seperate wallet for Ubuntu, because Ubuntu is also a linux build. You would need to provide complete details about the same.
Note that Yoroi is a light wallet while Daedalus is a full node wallet (i.e. with Daedalus you run a complete blockchain node, which means you will sync the entire blockchain to your machine as well).

1 Like

I sometimes run Daedalus on Ubuntu. It works fine in every single version of Ubuntu. You might have to make the install install file executable before running it… I did.

chmod +x file

Good to know that you are able to run the wallet on Ubuntu. I am not able to execute the file. I tired different methods for about two days, but even via terminal it asks for permissions, if I right click and permit the file to execute, then also I am getting the same error.
I will send you the screenshots soon, I am on a different system right now.

Wow, good to see that many users are able to run. You are right, I am not able to execute. But, I tried making it executable via different terminal methods. But, terminal says permission issues. Even after giving all the permissions to the file, it is giving same issue.
Also, how much space Daedalus takes in total? I have limited space to run a bigger software on my disk.

I just tried doing the same with the command you mentioned & with the root command too using sudo. Terminal asks for the password and then in the next line, nothing happens. No error code or information whatsoever.

Type ls in. If you are using the default ubuntu prompt the file should be green. That means it is executable. You can also check the permissions with ls -la that is beyond this post.

Then you can execute the file with ./file good luck. ./ means “in this directory” similar to, I’m sure you are familiar with ../ meaning “in the parent directory”.

Wishing you the best on your path to Linux familiarity. It’s a free tank (‘In The Beginning Was the Command Line’ by Neil Stephenson reference)!

Honestly, I am not aware of these commands, but I do use google and forums like this to get help from experts like you. The command you mentioned “ls in” does showed the file in green. But, after that, I am not able to execute it. It is clear that the file is executable, but the ./file command is not finding anything.

file was a placeholder for the actual name of your file :slight_smile:

so it will be more like ./daedalus-0.15.1-cardano-sl-3.1.0-mainnet-x86_64-linux-8695.bin

where daedalus-0.15.1-cardano-sl-3.1.0-mainnet-x86_64-linux-8695.bin is file with the executable permission enabled as a result of sudo chmod +x daedalus-0.15.1-cardano-sl-3.1.0-mainnet-x86_64-linux-8695.bin

fun links:

Welcome to the forum @jay11
You are not alone, I was never able to run Daedalus in my Ubuntu. I was told by IOHK representatives that it is now a matter of only one line of code to be written in the terminal, but anyway I was not able to do it (I am also not a developer)
Wish you luck! and also I wish that one day we will be able to install Daedalus as easy as Yoroi, which is the wallet I am currently using and is great

1 Like

Luckily, I just completed my installation. The only mistake that I was doing is not executing the commands from inside the directory. As I do not know coding at all, I was not aware of this. Read somewhere and executed. It worked like a charm.
It is actually a matter of few lines. For newbies like me, it is just about right execution.


Thanks for all the help. My stupid mistake was that I was not launching terminal within the directory. It solved everything. I simply executed the commands you mentioned. But, even after this much efforts, the disk space is just 5.8gb which i think is not enough for the whole node. Anyways, it was a good learning experience.
Thanks once again.

Nice! You definitely need a substantial amount of space and I’m fairly certain < 6G won’t cut it.

But… Yoroi. Yoroi is a fantastic user experience and it supports Ledger and other hardware wallets and has many virtues. Highly recommended if you’re not going full chain.


Yes, you are absolutely right. After ditching Daedalus due to low memory, I have installed Yoroi and using it already.
Thanks for all the help… :slight_smile:


1 Like

Friendly reminder to keep excellent care of your private key and maintain the most excellent Opsec you can, especially if you plan on hodling a respectable sum of crypto. I would recommend something like the billfodl or just a well guarded piece of paper if you must.

Don’t lose your key. Don’t distribute or compromise your key.


the replies cleared all my doubts, thanks !!

no repllyyy…..???