Cabal can't find cardano-submit-api

I’m following the documentation in cardano-node/cardano-submit-api at master · input-output-hk/cardano-node · GitHub and one of the steps is to run install cardano-submit-api --overwrite-policy=always. However when i do that cabal returns cabal: Unknown package "cardano-submit-api".

Am I the only one encountering this error? If not, what are the other ways to only install the cardano-submit-api?

Check this guide shared by @PANL-Ryan


1 Like

the guide references the same link I shared above.

If I understand that correctly, you have to already have cardano-node installed (e.g., as per Installing cardano-node and cardano-cli from source | Cardano Developer Portal) and be in its directory to do that. The cardano-node $ indicates that you have to be in the source directory checked out of github in those installation guides in order to run the cabal install.


ooh that makes sense, i will try this thank you


This is the correct answer, I will add some more notes to the guide.

1 Like

One point I’d like to emphasize for MacOS users is the LLVM error.

When I ran cabal install cardano-submit-api i kept getting errors about LLVM.
I ran brew install llvm but the fact that macos had its own version of flvm made the compiler use that instead.

So i had to modify the $PATH via vim /etc/path and set the first path to /opt/homebrew/opt/llvm/bin. Maybe @PANL-Ryan can mention this in the guide too.

1 Like

Will do, no macos enviro here for testing, but it sounds like that will be next on the list to improve my documentation writing process.

Thank you for the feedback!

1 Like

It is already in Installing cardano-node and cardano-cli from source | Cardano Developer Portal, but perhaps, you should reference that back in some detail.

1 Like

Little rusty on macos but definitely would not recommend using sudo with brew … brew install llvm is enough to install to your local paths. Then you can use export PATH="$PATH:/usr/local/opt/llvm/bin" for a temporary build shell that won’t override Mac defaults or echo 'export PATH="$PATH:/usr/local/opt/llvm/bin"' >> ~/.zshrc to make it permanent for all new shells if you don’t care what Apple wants.

1 Like

I have had the same problem. Let me know if you find a workaround…

which problem are you referring to exactly?

I got it