Can not generate keys

Ok…last one

Can u show me the cnode script?

1 Like

Here is the image of the cnode script.

Thanks

you changed it

please correct it, should looks like that

cardano-node run
–topology “{TOPOLOGY}" \ --config "{CONFIG}”
–database-path “{DB_DIR}" \ --socket-path "{SOCKET}”
–host-addr 0.0.0.0
–shelley-kes-key “{POOL_DIR}/{POOL_HOTKEY_SK_FILENAME}”
–shelley-vrf-key “{POOL_DIR}/{POOL_VRF_SK_FILENAME}”
–shelley-operational-certificate “{POOL_DIR}/{POOL_OPCERT_FILENAME}”
–port ${CNODE_PORT}
else

1 Like

dont forget to acticate the
POOL_FOLDER="${CNODE_HOME}/priv/pool" # Root folder for Pools
if i see correct line 18

1 Like

this some good stuff , thank you though !!

1 Like

thanks I missed that.
Cheers

I changed everything in the cnode.sh below are the changes

start the cnode.sh again and I get

Invalid argument ` ’

Usage: cardano-node (run | [--help])
  Start node of the Cardano blockchain.
./cnode.sh: line 41: --shelley-kes-key: command not found

hmm weird… try to delete your script and add this one:

https://www.charity-pool.ro/cnode_script.txt

nano cnode.sh
Ctrl+k to delete row by row
Paste the new code…
save
and run again

1 Like

case sensitice
you need tab

1 Like

this is your script
has not spaces on line with --shelley-kes-key
–shelley-vrf-key-
–shelley-operational-certificate
Screenshot 2021-01-15 at 2.15.56 AM

1 Like

Yes you were right my mistake on the case sensitive on the cnode file.
Thanks

1 Like

Just wanted to say before I post the next problem that I have never received this much help online in anything thanks a ton.

I copied the contents of the file and restarted the node worked okay went to cntools went to pool-show and still have the same error. I see that it says my name of metadata file is different even though I did go to pools-modify to change it. Should I modify it again and rename the file to that name that.

1 Like

Ok, tell me when are u online to continue.

We need to solve this issue with metadata also

edit it, upload to site, and announce me after (don’t run cntools again)

should look like this (try to write it in notepad, not to copy paste … perhaps some character will be change if you copy paste it)

{“name”:“Amarii”,“ticker”:“AMAD”,“description”:“Stake Pool”,“homepage”:“https://amariiltd.com/amad”}

cheers

2 Likes

Hi,

as a hint I always run these commands automatically to check if the hash number is the same:
cardano-cli stake-pool metadata-hash --pool-metadata-file <(curl -s -L https://git.io/JtepM)
cardano-cli stake-pool metadata-hash --pool-metadata-file <(cat poolMetaData.json)
This is an example for my pool.

If you see the same hash number then the issue is somewhere else. Please check this first.

Best,
Johann

Thanks I changed the file hosting to github seems something was wrong with my website. I show up in Adapools and Cardano PoolTool. The files have the same hash! Something is wrong with my website! Thanks for all the help. Cheers

I did this and used github and all has been solved! Thanks

1 Like