Cannot send a NFT

Hello there,
I have some issues when trying to send my NFT to another wallet address. Currently, I minted thousands of NFTs, after I sent around 20 NFTs to others, and now I cannot send any more.
If I tried with Daedalus wallet, the fee is very high ( ~ 6 ADA per transaction).
If I tried with Yoroi wallet, I got a message Error from server
If I tried with CLI, I got the error BadInputsUTxO since I found the right transaction as input for that NFT.

Any clues?

Thank you so much!

I don’t think that changing the wallet u will pay less fee

could be related:

Yes, I think so.
But the issue is why do we need to pay the high fee? because last time I only need ~ 1.9 ADA to send an NFT out?

Thank you so much. I will check it

also check this fresh documentation:

Thank you,
But even I accept the fee and sent NFT out of my wallet on Daedalus wallet, I still got the error

I assumed that cardano blockchain network merged all UTXOs to one. And now it is too long (because we have thousand of NFTs) so cardano got stuck when calculate tx-in and tx-out (the time out got from server, I think)

if that is the case i would submit an issue on github to indicate this behavior for developers:

Yes, I did it also. But if you can please do it

What is the link for the ticket?

You can check on github Issues with wallet containing many unique native assets · Issue #2622 · input-output-hk/cardano-wallet · GitHub

Glad that you got support from developers!

do you guys know a solution fro OutputTooSmallUTxO?
I’m trying to send 9 tokens to another wallet and passing 2 ada.

I’ve had trouble doing this with Daedalus sometimes, but Yoroi always worked fine. Using cardano-cli is another option.

If the tokens all have different policy IDs and long asset names, you might need as much as 4.3 ADA to meet the min-ADA requirement: see here.