Cardano cli did not download with build all function

I built the node using:

cabal update
cabal build all

However, when I use the function:

cp -p “$(./scripts/bin-path.sh cardano-cli)” $HOME/.local/bin/

I get this:

Error: cardano-cli not built
cp: cannot stat ‘’: No such file or directory

Please advise.

Did it built cardano-cli correctly? You can see that in the in output of the build process. If already built and you don’t have output anymore, just start build command again, it’ll only do what isn’t done yet (assuming you didn’t remove or clear anything).

Also you can try ‘cabal build cardano-cli’ if build all succeeds completely without having built the cli.

Thanks so much man! it worked with ‘cabal build cardano-cli’ !
Interesting why it didn’t build with ‘cabal build all’

1 Like

I think because cardano-cli isn’t part of the node repository anymore, but resides in its own repository now (with seperate version numbering and stuff).

2 Likes

Hi folks. im facing the exact same issue when upgrading to 8.9.1 . cardano-node updates properly, but cardano-cli does not get built with cabal build all. I tried cabal build cardano-cli but i get the following dependency errors. it is strange (ps: im upgrading from source as always, and i have blst, libsodium and secp built properly)
Screenshot from 2024-04-06 08-59-47

Thank you, especially because this is not stated in the official Cardano documentation it was supremely frustrating!

Have you removed your old 8.9 Cardano-Node?

1 Like

what do u mean remove? Im building things from the source. I checkout the latest git tag and follow the process as per the dev portal guide. Do i need to remove something (old binary) from somewhere?

there is only one cardano-node binary in my local/bin
cli