Cardano NFT

Is there any web page where we can check our testenet NFTs.

policy id: 58faf7bf57452fd08c34d535465fde39a016f61f26fbc05f8748048a
assetid: asset1pnkrkclfcgpm0epnvv8l2fsadl4z37vsx9wgpm

Created this asset on testnet.

The asset is not showing in Nami wallet. Can anyone suggest me what I need to do for getting the asset on Nami wallet.

Hello @Suman_Saha

To switch Nami to testnet follow these steps:

  1. Left-Click the avatar icon in the top right of Nami window
  2. Left-Click ‘Settings’ from the drop down menu
  3. Left-Click ‘Network’ from settings menu
  4. Then just move slider from Mainnet to Testnet :point_down:

Your asset does show on testnet, so if it’s in your Nami wallet under correct Nami address it should be visible after you make that switch.

I changed the Nami wallet network to Testnet but it is still not available in Nami wallet.

The tokens are on the address with which you have minted them. You never sent them to your Nami wallet. So, how should they be visible there?

Moreover, if you send them to Nami, they will show up in “Collectibles”, not in “Assets”, since you added metadata with the label 721 to the mint. The creator of Nami (and author of the metadata CIP) has the strong opinion that these metadata are only for NFT and therefore displays all tokens that have them in the section for NFTs.

1 Like

In reply to Suman’s thread. We are able to mint and it is coming it as a normal transaction. Please refer to the screenshot.
image. Can you please help?

If you look at the transaction:

Only the change ADA (998.462985) went to the Nami wallet. The minted tokens together with their minimal accompanying ADA (1.347798) went back to the address you were minting from.

I would have expected to do it exactly the other way round: Leave the ADA in the minting address for future mints and send the tokens away to the wallet you want to use them in.

1 Like

This is the sample transaction of the NFT that we minted, and it is coming under transaction not under assets


Thanks for advise. We will check and get back to you. Seems we have a solution.

That is exactly the transaction that I also sent to you in the previous message.

You can see that you did not send the assets to Nami.

You only sent ADA to Nami.

The minted assets went back to the address you used for minting.

If you use cardano-cli: You need to specify that the assets shall be send to Nami in the --tx-out parameter.

You can also first mint them and then send them away later. But that is not possible at the moment, since the ADA remaining at the minting address are too few. You’d first have to charge that address again.

Thanks. Can you please specify the parameter needed to send any assets to my nami wallets in --tx-out?

For your example, it would have been:

--tx-out "addr_test1qznf8t2aht6udeq3ecu2w3ajatvt242ym5jakr3nf8y693jwv8dtrrnv44keayz6wzdyxpgwaq7xzq4h6qqv7p6wk4yswy694t+1347798+10 58faf7bf57452fd08c34d535465fde39a016f61f26fbc05f8748048a.74657374"

In general, the structure is:

--tx-out "<Address>+<Lovelace>+<Amount> <Policy ID>.<Asset Name in Hex>"

The quotes (") are necessary, because that string contains a space between the amount and the policy ID and the shell would otherwise interpret that as separate arguments.

1 Like

Thanks a ton. Let us verify and get back to you!

Hey, it worked. Thanks again. Much love.

@Hepta Sean your information resolved my issue. Thank you very much for your clear instruction. Thanks a lot.