Nami wallet testnet is out of sync with Cardano node?

Hello all,

I have just switched to the testnet mode of Nami wallet and tried to add some funds (tAda) to my wallet using Cardano Testnets Faucet. Faucet showed me a successful response with transaction hash which I verified through CardanoScan. You can check it from here.

Problem is that the fund isn’t showing in my Nami wallet. I tried the same with Yoroi Wallet and the result is the same. It’s been 18 hours since I am debugging and still no luck.

Can anyone tell me if I missed something?


Testnet has been a bit messed up since 1.35 … probably due to issues being worked out with Vassil fork. For me some API stopped working, transaction fees were incorrectly calculated causing tx failures, then more recently there was a sync issue. Things dependent on 3rd party API like blockfrost etc may take longer to get updated. I’m not sure if anything has been fixed yet as I moved on to other tasks I can actually test successfully. Will try testnet again next month …

The old testnet has been abandoned, since they totally broke it in the tests for Vasil hard fork.

There are now two testnets: Preview, getting new features earlier and already on Vasil for quite some time, and Preprod, don’t know if that was forked to Vasil, I think not, supposed to be the more stable of the two testnets.

Your link to Cardanoscan indicates that you sent the tADA on Preprod.
But Nami still seems to point to the old, broken, and abandoned testnet.
Use a wallet app that already supports the new testnets like Eternl or Typhon.

As said: Was unfixable, old testnet mostly abandoned now, faucet is no longer reachable, wallet apps, explorers, APIs, … are moving to support the new testnets and abandon the old one.

The bug resulted in the old testnet working with version 1.35.2 and 1.35.2 only, not any newer version of cardano-node. You will probably want to abandon it also. (Although, I think there were some talking about keeping it running for the lulz.)

1 Like