Cardano-node-services - LOADING - should I run something else?

My relay node looks to be loading… Is this right? Do I just wait? How long do I wait for? Or should I run another script?

Thanks in advance for your help! Having a hard time getting my node display running

cardano-node.service - Cardano node service
Loaded: loaded (/etc/systemd/system/cardano-node.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Sun 2021-05-30 08:25:13 UTC; 1s ago
Process: 106320 ExecStart=/bin/bash -c /home/wind/cardano-my-node/ (code=exited,>
Main PID: 106320 (code=exited, status=127)

May 30 08:25:13 wind systemd[1]: cardano-node.service: Main process exited, code=exited, status=127/n/a
May 30 08:25:13 wind systemd[1]: cardano-node.service: Failed with result ‘exit-code’.


journalctl -e -f -u cardano-node

This “error in loading shared libraries” shows up for many lines

U can see the error, can’t find the libsodium, check the path… what guide did u followed?

I reinstalled libsodium from another post.

sudo apt-get -y install libsodium-dev
export LD_LIBRARY_PATH="/usr/local/lib:$LD_LIBRARY_PATH"

it worked! now the LiveView dashboard is showing… is it normal to be status: “starting” for a while?

Perfect, after a while u should see syncing

how long is a while? It’s already been 4 hours of syncing and still in “starting” mode with 0% percentage, epoch 0

Probably the node is syncing… if u type top do u see the CPU 100%?

only 1.3% cpu

I am see the same thing… waiting for cpu 100% status says starting…

1 Like

try journalctl -e -f -u cnode

and sudo systemctl status cnode what is the status and the uptime?

Active, 5h 7min

Ok, show me the topology file

U must keep only the IOHK nodes till the node will be fully synced

then restart the node

sudo systemctl restart cardano-node

Wait more minutes and check glive again

The topology file was my problem… thanks! After I restarted, killed, and restarted the node again it was running. It’s still going through “starting” mode but hopefully it’ll work out this time.

CPU is still 1.5%-3%

Actually - I misread. The total sum of CPU on the top row is 100%.

and if u ar typing now journalctl -e -f -u cardano-node

what do u see?

glive still shows starting?

gLive still is starting

Similar reoccurring lines. The one line that stands out is:
May 30 14:48:39 wind cardano-node[449891]: cardano-node: FatalError {fatalErrorMessage = “Cardano.Node.Run.handleSimpleNode.readTopologyFile: Is your topology file formatted correctly? The port and valency fields should be numerical. Error in $: endOfInput at ‘]’”}
My topology file is the text you sent over earlier.

Here’s a sample screenshot:

can u attach a picture with the topology file?