Cardano stake pool .. success eludes me

Hi … I have tried to make a cardano node from Source and Using Nix umpteen times … and have done one Ubuntu 18.04 and Linux mint 20 but it seems I get stuck … I have followed the instructions from Cardano page and also used Git forum and used it also … ams also tried using YouTube videos and I’m not getting any success … I’m frustrated now but still want to do it as it’s now kind of a challenge… can anyone have the heart to help me around and take me through it … Its more about understanding what I’m not doing right in those umpteen times I have tried
SOS please

Sorry to hear. Maybe this walkthough is useful:

Hello Hash Griffin,

You will have to be more specific.

Please let us know exactly where you are getting stuck, and what specific errors you are seeing. I personally am familiar with Ubuntu setups.

Please observe your logs as well for any clues, and pass that data on as well.

Your friend - FROG

Hey Thanks for the reply… these are the instructions in following exactly

i think the problem is here
‘’ Add overwrite-policy: always in .cabal/config -file’’
not doing this right i think

thanks for the reply,…im doing it again just now…will post the error logs

not being able to do it.
can u take me through the whole process…? maybe im missing some tiny bit somewhere

What you can also do: check whether “cardano-node” and “cardano-cli” already exist under the folder “~/.cabal/bin”. Delete them first before rebuild.

I am sorry, Hash - that’s not really a fair question to ask - please let us know exactly what is going wrong.

Before running cabal build all again, run the following:

cabal update
cabal clean
cabal build all

1 Like

Here is another easy way to setup and configure the nodes (thanks to Cardano community members):

I didn’t have any trouble with building from source, but the Nix path of installation, the one recommended by IOHK, was problematic at best…I never got anywhere with that installation, and a I spent a few days on it. The directions given simply don’t work on ubuntu 20.04.
You do the first step
curl >
and what you get is an empty file.

So, then you can paste in the browser url field, hit ‘enter’ and a pop-up windows asking you if you want to download the ‘install’ file. So after you download it, change permissions (executable) and run it, it works, but only if you log out of your session and log back in, but dropping into a Nix shell to do the installation has eluded me. Sometimes I get a nix shell other times, the nix-shell doesn’t work because it’s looking for a file it can’t find because the path is bad. I wish there were a fool proof way to install via Nix, but no success so far. I think there are extra instructions missing to make this install much easier.

i tried that too…using Nix build…but problem starts after ''nix shell ‘’ environment installation…after that it starts giving errors

now Iam facing problems with ‘’ genesis , configuration and topology ‘’ process
im attaching the screenshot for reference…cant download all the three topology files.
kindly see and guide .clog 1.pdf (237.0 KB)

I’m assuming that you want to connect to the mainnet? If that case, then download the next files:

wget -O configuration/topology.json
wget -O configuration/byron-genesis.json
wget -O configuration/shelley-genesis.json
wget -O configuration/config.json

Once done, then update the next information in config.json:

BTW: the procedure to calculate the transaction fee, has been changed a little bit. Please check the next link for the latest instruction:

when I tried using various distro’s of linux (debian, redhat, linuxmx, mint, ubuntu [18 and 20]) to no avail. Each distro had its own set of conflicts and problems that I had to resolve.

I found that when doing the AWS tutorial I did not run into these same sets of problems - leading me to believe that the more complex the OS is, the more potential for potential conflicts - thus I would recommend (from personal experience) to use a bare-bones command line linux. That’s where I’ve had the best success.

I almost finished the installation today, but was foiled once more:
Here are the directions from Cardano for installing the cardano node using Nix:

They don’t work at all, so I finally figured out how to do 99% of the install…I’m stuck on the very last part.

Here are the steps I’ve done so far:

sudo curl -L | sh

sudo mkdir -p /etc/nix

cat <<EOF | sudo tee /etc/nix/nix.conf
substituters =
trusted-public-keys =

nix-shell -p

under nix-shell we do the following:

git clone

cd cardano-node

nix-build -A scripts.mainnet.node -o mainnet-node-local

The previous step are where things go bad:
I get a mesage saying the the install was interrupted because I ran out of space, but when I check df -h, there’s plenty of space on the primary partition (/root and /home).
So it must be the inodes or the memory perhaps.
I checked the inodes df -hi, and eight /dev/loops were being used up 100% by ubuntu snap, so I deleted the snap directories and purged the snap daemon, and the inode situation was OK because after that there were lots of inodes available, but when I ran the command again, I got the same error, so I though maybe it’s the memory that’s running out of space, but I saw 0% growth in memory while running the command again with swapon running.

So it’s neither the memory nor the inodes nor the root partition that are running out of space.

Maybe just going into a nix-shell fools the system into thinking it has run out of space. I don’t know, but I’m almost finished with Nix installation.
Once this is done, the last step is to launch the Cardano node via script ./mainnet-node-local

tried till the topology and updation of config files .
when i run the node …i get the following response

InvalidYaml (Just (YamlException “Yaml file not found: relay/configuration/config.json”))

cardano-node: YAML exception:
Yaml file not found: relay/configuration/config.json

Hi Hash,

You need to specify the full path to both your topology and configuration files within the node start command you are using - please review linux file paths and make sure the file names referenced in the node start command reflect the actual file names

Please see this thread for reference:

1 Like

not happening my friend
i guess i should stick to baseball…lol!

F£$%^&* tired and exhausted