CNCLI Leaderlog Issue Since 1.35

Hello -

My block producing node is presenting an error when I run leaderlogs since I’ve upgraded to 1.35. Here’s the error:

error: Found argument ‘–consensus’ which wasn’t expected, or isn’t valid in this context

Anyone else have this issue?


Did you update to latest CNCLI version 5.0.2?

Please use --consensus tpraos before babbage era and --consensus praos for it.

Hi there! Thanks for the reply. I didn’t explicitly do an update, but when I ran leaderlog recently it asked me if I wanted to update and I said yes… Does that bring me current to 5.0.2? Or do I need to manually update?


Not sure what script you are running, but error what you are getting is implying that CNCLI doesn’t expect –consensus argument. That argument is available from 5.0.0 version. So my guess is that your script expects latest version of CNCLI binary.

If you will update your CNCLI binary, everything should work.

U will need to run (if u use cntools)

cd ~/tmp
./ -c
1 Like

Looks like this was the issue! Thank you @Alexd1985!

1 Like

Yw, anytime :beers:

Whoops… Spoke to soon… The update ran, but it looks like it only tried to update to 4.0.4? Afterwards, I received the same error when attempting to run leaderlog…

Installing CNCLI
previous CNCLI installation found, pulling latest version from GitHub…
CNCLI already latest version [v4.0.4], skipping!

Ok, perhaps the new version is not pushed to updates yet? …

Yes, could be… Ok, I’ll be patient :slight_smile:

as workaround you can remove –consensus argument from your script…


Hi, and the CNCLI binary are two different things. The script calls the binary, however. When the script prompts you to update, the script is updated.

You also need to update the binary manually as a separate procedure. The current version of the binary is v5.0.2 GitHub - cardano-community/cncli

Maybe file a bug report with Guild Operators to address the confusing naming GitHub - cardano-community/guild-operators: Artifacts and scripts created by Guild operators


You are looking on alpha branche… switch to master… the script was not released for update… yet

I also encountered this problem, it can be solved by updating the cncli version

rustup update
cd cncli
git fetch --all --prune
git checkout v5.0.2
cargo install --path . --force
cncli --version