Error when running CNCLI leaderlog after 1.29.0 upgrade

Hi, After successfully updating my node to 1.29.0 and running CNCLI v4.0.1 command “leaderlog”,

I get the following error:
image

and consequently the leaderlog is not updated in the gLiveView window.

Any ideas what could be the reason?

1 Like

Hey, I’ve had the same issue. Check out the new scripts cncli/scripts at develop · AndrewWestberg/cncli · GitHub

Thanks for the suggestion. I downloaded and edited the scripts and got them to work for my pool, e.g.:


so in a sense they provide the info I am looking for :slight_smile:

However the “cncli.sh leaderlog” command (from CNTOOLS) is still not working and would be useful to update the gliveview info in the “BLOCKS” section:
image

So still not sure why “./cncli.sh leaderlog” command provides the error shown in the 1st post after I updated to 1.29.0 and cncli v 4.0.1 …

I ran today the CNCLI and no issues, try nano cncli.sh do u have lines edited there?
did u tried to update the cncli script?

cd ~/tmp

./prereqs.sh -c

Hi
I reinstalled using your instruction. It skipped installing CNCLI, but everything looks ok as far as I understand:
image

In order to try forcing a reinstall, I then deleted the CNCLI file and tried the "prereqs.sh -c " command again.
However this time it ends in an error:

image

Which file did u deleted? Cncli.sh?

no the cncli executable:
image

then try to run again prereqs.sh and after this prereqs.sh -c

same error…
image

Can u go on your reley and check for that folder that u deleted, is it present there?

no it is empty:
image

Try to install the cncli on relay and upload the folder to the producer

If you want you can give me an email and I can send you the binary, Why you delete the file?? Do you have the lastest version of cntools repository files?? You can run ./cncli.sh --help under scripts folder to see how to work with the script and operations and sub arguments.
Or you can run as a systemd service go to Node & CLI - Guild Operators and checkout that