Cncli.sh sync error: failed to fill whole buffer

Hello Community, I am getting the following error when running cncli.sh sync on my core machine. May be an issue after upgrading to 1.29.0 as I have never seen this before. Any ideas on how to fix it?

sync error

Update the script

For cntools users

cd ~/tmp
./prereqs.sh -c

Done, but still have the error, updating the script installed the latest version of Rust which I thought would fix the problem. Do I need to restart the machine?

I can see that if I run prereqs.sh again it shows version 2.1 is installed instead of v4. For some reason the update is not overwriting the old version. I renamed my scripts folder and ran prereqs.sh again as you mentioned in this post How to update cncli to the latest version on Github for Cntools users? - #4 by DenisHR1 but still no joy. I updated my env file after the new scripts folder was installed.

command -v cncli

/home/core/.cargo/bin/cncli

cncli --version

cncli 4.0.0

because u need to run prereqs.sh -c … did u ran it this way?

yep, several times

working now, I deleted the scripts folder again and then ran prereqs.sh -c, error gone! Thanks Alex.

1 Like

Nut now u must edit the env file… did u edited back right?

yep did that, there was only a couple of variables that needed changing. Also changed the cnode.sh script to use 4 cores.

hmm, how many cores does it use by default? and how did u changed it? thank you
I thing I saw with htop that it’s using all cores but not same time…

#CPU_CORES=2

is the default value. I changed it to:

CPU_CORES 4

as my machine has 4 cores. I’m not sure how many it uses by default, I assumed 2

1 Like