CNTOOLS Multiple pool registration certificates error - using hw wallet

have this error when I am trying to sign pool registration via my hw wallet on my offline node. I did use hybrid mode to register pool, and did not choose any multiple owners.

Do you want to sign Pool Registration with: Owner #1 ‘PSYA’ payment signing key ?
Selected value: [y] Yes

INFO: follow directions on hardware device to witness the transaction
Error: Multiple pool registration certificates found, expected one <<<<<<

This options I have used on my online node (future BP). No multiple owners chosen.

Select main owner/pledge wallet (normal CLI wallet)

Selected wallet: PSYA (XXXXX Ada)
Owner #1 : PSYA added!
Register a multi-owner pool (you need to have stake.vkey of any additional owner in a seperate wallet folder under $CNODE_HOME/priv/wallet)?
Selected value: [n] No
Use a separate rewards wallet from main owner?
Selected value: [n] No

Any ideas how to solve it within cntools? I am kind of lost in the cntools folder structure.

First u need to create the wallet in cntools and after u can use it to pledge with it!

So use cntools- wallet- import - hw wallet first and after u created the wallet and files for the wsllet u can use it to pledge

U should see the files in priv/wallet/new_wallet folder

Sure I did that first and wallet was registered online with signature offline. This worked well, but I can’t sign the pool registration with my hw wallet.

And do u have in priv/wallet/PSYA folder right?
and inside u should have the files requested like stake.vkey, etc

Yes, all is there. Actually the error is there while choosing the first file xx.hwsfile and error comes out after the ledger connection.

When I pledged from hw wallet, I created a new wallet for pool registration and rewards; then I imported a new wallet and used ledger… it generated a new wallet;

After this I registered the pool first with the simple address and for the next step (pledge) I used hw wallet… and it worked well. But I did this on my local node and after I uploaded the file to the life Producer

So if I understand it correctly you have used the cli wallet with 500 ADA to register the pool. And then used the next address from hw wallet for pledge, so that means you have chosen multiowner option in cntools?

Yes, that is correct

The cli wallet should have few more ADA for transactions fee

Ok, thanks, will try like that later today. And you can use your hw wallet address as your reward address, right?
I want to have everything on my hw wallet so far. So if it’s just the registration deposit payed by cli address, then it’s ok.

1 Like

Nope, the pool rewards (cost + margin) will go to cli wallet; the rewards for pledge will go to hw wallet
Because when I tried to register the pool directly from hw wallet I had a warning… I will try to find it and I will upload here… wait


Read the error from the end


1 Like

Hi Alex,
thanks so much.
It was a bit workaround doing it this way, but it actually worked.

Pool is registered and ready to mine.
I am a multiowner of my pool, the cli address was used as basic pledge/reward address and hw wallet address as a second owner.
Main pledge is on HW wallet.