Unable to select/add Ledger HW as pool owner

Hello Cardano Forum,

TLDR: Unable to connect BP with Ledger X and verify as pool owner with Ledger wallet.
Been following this guide Adalite-cardano-stake-pool-owners-hw-support

I am unable to build a stake pool registration certificate file from my BP node with my ledger stake key. I have downloaded the Staking Key through AdaLite and transfered stake.key to my BP node, but I am unsure what to do next.

I run BP and relay’s on VPS. I am using cntools to manage my pool which is already running. I am unsure if i re-register I will have to pay a new 500 ADA fee, since I change the stake_key.

Is it correct, that I need to re-register my pool with the new stake_key from AdaLite now locally on the VPS, and then transfer a file back to upload on AdaLite?

Also found this guide (https://docs.cardano.org/projects/cardano-node/en/latest/stake-pool-operations/register_stakepool.html)
but needs to stop at 8.9 and then transfer that file back, or? Really unsure here.

Best regards,


First of all u can’t use a hw wallet as a main wallet; u will need:

  • a new wallet for tax registration and transactions fees
  • u will need to do this operation to a local node like VM because u need to connect ur hw wallet and export the files… the files look like:



Have a look this - it explains the procedure quite well

Hello again,
Thank you for your quick reply.

When you say a new wallet for tax registration, do you mean the 505 ADA for the pool?
I retire my current pool and register a new one with these files?

This is exactly what I was looking for :slight_smile: Thank you very much.

So to clarify:
I need to retire my current pool and re-register it using cardano-hw-cli (unsure how to else since I paid 505 already?), following this guide to the “Build the tx” section where output is tx.raw and pool-registration.cert file.

Then I transfer the pool-registration.cert file back to the hardware wallet owner, and owner submits the tx.raw file on AdaLite as their guide mentions. https://miro.medium.com/max/582/0*-lbL42DEDi0bFz5M
Correctly understood?

Sorry if this seems like a no-brainer to you. Been picking my brain the last few days trying to register the hardware wallet with no progress. :expressionless:

NOpe, you can keep your new wallet because hw wallet can’t be use as main wallet when you register the pool.

HW wallet can be use as 2nd wallet to pledge for pool
If you already have a wallet and u registered the pool, there is no need to retire your pool;
keep the wallet as main walleet for the pool, and now you will need to import HW wallet which will be use for pledge

1 Like

Hello Alex:
I have a pool and I have all pledge on pool wallet, I just received a hardware wallet, how can I move all ADA from server to HW without causing a delay on stake interest and pledge.

Lower the pledge to 1ADA wait 2 epochs and after sent the funds to ledger wallet… after that pledge with the ledger…

PS: I don’t know if the rewards will be afected if u will not wait 2 epochs (sending the funds to ledger wallet (u will not met the pledge) and immediately pledge will ledger (the pledge will met again)

Maybe some one else can confirm/infirm

can I pledge from multiple wallets?

Yes, u can

Maybe I could just start pledging from another wallet and just move all ADAs to the new wallet, I think it will sync again

I am 90% sure that if u only move the pledge from one wallet to another should not be a problem… only if u lower the pledge u must wait for 2 epochs in order to withdraw the pledge (because of the snapshot)

How could I add a second pledge wallet it will also be the rewards wallet, is it in pools or do I need to register under wallet?

The pool rewards will go to pool wallet… the rewards for pledge will go to ledger… because u can’t use a hw wallet for main wallet (pool wallet)


But I need to create the wallet first right under wallets?

is prompting me to run prereqs.sh -w to install support for hardware wallet, can I run into any problems if I run prereqs.sh> will I need to restart node?

I ran prereqs.sh -w but I still get this error:
ERROR: need ‘cardano-hw-cli’ (command not found)
try ‘sudo apt install cardano-hw-cli’
please install with your packet manager of choice(apt/yum etc…) and relaunch CNTools
ERROR: cardano-hw-cli executable not found in path!
Please run ‘prereqs.sh -w’ to add hardware wallet support and install Vaccumlabs cardano-hw-cli, ‘prereqs.sh -h’ shows all available options

Are u using cntools?

yes cntools

Then run also prereqs -w
but… ur serve is on cloud right?