Coincashew Step 13 - Can't see my pool on pooltool

I did run after cabal build all in the cardano-node folder, just like how I did in the core node, hmmmmm

cp -p "$(./scripts/ cardano-node)" ~/.local/bin/
cp -p "$(./scripts/ cardano-cli)" ~/.local/bin/

Copy the files from producer to the relay from /usr/local/bin if u can… and try again or try to find on relay where the files are located

lol already did that Thanks. But… now the problem is:

<socket: 11>: does not exist (No such file or directory){ "resultcode": "502", "datetime":"2021-09-09 20:18:07", "clientIp": "", "msg": "invalid blockNo []" }

did u copied all the files? Also try to restart the relay… also check for the bash file on both nodes

nano $HOME/.bashrc

Have both nodes same exports lines (at the end)?

Yes both have the same files in bin now and both have the same export paths in bashrc.
After making sure of that, I restarted the relay and ran

Network.Socket.connect: <socket: 11>: does not exist (No such file or directory)
{ "resultcode": "502", "datetime":"2021-09-09 20:37:16", 
"clientIp": "", "msg": "invalid blockNo []" }

what file or directly is this looking for? any ideas? maybe my paths are not correct in the topologyupdater. but not sure which one needs attention. Most likely need to remove quotes or put quotes around the path. is my guess.

Ahow me the first 10 lines from

CNODE_PORT=3001 # must match your relay node port as set in the startup com>
CNODE_HOSTNAME="x"  # optional. must resolve to the IP you ar>
NETWORKID=$(jq -r .networkId $GENESIS_JSON)
CNODE_VALENCY=1   # optional for multi-IP hostnames
NWMAGIC=$(jq -r .networkMagic < $GENESIS_JSON)

Also the export lines (there are bellow.)

export PATH="${CNODE_BIN}:${PATH}"
export CARDANO_NODE_SOCKET_PATH="/home/cardanorelay/src/db/socket"


cd /home/cardanorelay/src/db/socket

do u see the socket file there?

Try to edit the line like above, save the file and run the script again


Wait. is there supposed to be home/cardanorelay/src/db/socket? because I see /src/db/node.socket. but no socket folder inside the db folder.

also, I get the same error when i do

Then check where the socket fike is located
Type pwd , copy the path and paste inside topologyUpdater to export socket path

isn’t node.socket the socket file?

Yes, node.socket

so that is inside /home/cardanorelay/src/db/ folder the exact path is: /home/cardanorealy/src/db/node.socket

which is listed in the updater… so that cannot be the problem.

Then adjust the path

FIXED IT! THANK you for your patience! Alex! You are a life saver.

{ "resultcode": "201", "datetime":"2021-09-09 21:02:29", "clientIp": "x", "iptype": 4, "msg": "nice to meet you" } 

Type ifconfig