Daedalus testnet missing stake pools

Daedalus testnet V1 was working fine. Had to restart a few times, but always came back.
At the start of epoch 5 all stake pools disappeared, and it says I am delegated to an unknown stake pool??
Anyone else have this issue??


yes, here for exactly the same issue. will check the telegram channels, please update us if you find out anything.

Same issue here. Delegated to unknown stake pool.

1 Like

Following; same problem here. I’m hoping that my last delegation to IOHK will continue collecting rewards if I ignore this wallet issue…? Would be nice if someone can confirm. I could probably delete the testnet wallet and re-download the whole thing again, but I don’t want to do that again right now. Is it safe to assume that local issues with the wallet would not affect the delegated stake and ability to collect rewards? (I did receive some rewards before this issue came up)

found this, but haven’t tried it yet:

Fix for problems with Daedalus Incentivised Testnet V1 wallet - Mac

I figured I’d share this as a new post since I’ve seen many questions concerning similar problems in various posts.

I had a number of different problems (0 balance, no stake pools showing up, delegated to “Unknown”, not connecting to network, etc.) with the Daedalus testnet wallet on my Mac but these steps have so far solved things for me:

Close the testnet Deadalus wallet.

In finder navigate to Macintosh HD > Users > “your user account” > Library > Application Support (If you for some reason do not find the folder here follow the instructions further down, you might have the folder in another destination)

In here delete the whole folder called “Daedalus - Rewards v1”.

Then start the Daedalus testnet application, this basically resets the application, and just enter in your seed phrase and you’re good to go.

Restart your computer (if you are using a Mac make sure that you do NOT have “Reopen windows when logging back in” selected).

No need to uninstall and reinstall the software.

You can also get to the folder Finder destination by clicking on the 3 symbols on the bottom of the window when you start the Daedalus wallet, before it connects and opens your wallet. Then you see a row called “Daedalus state directory:” next to this one there is a button labelled “OPEN”, this takes you directly to the folder destination in Finder. Now just close the Daedalus testnet and then delete the whole folder “Daedalus - Rewards v1”, restart your computer and then open Daedalus testnet again.

Hope this helps. Happy staking!

Post image

thanks for posting that!

what worked for me was to delete the sql-lite db.
where: Macintosh HD⁩ ▸ ⁨Users⁩ ▸ ⁨username ▸ ⁨Library⁩ ▸ ⁨Application Support⁩ ▸ ⁨Daedalus - Rewards v1⁩ ▸ ⁨wallets⁩ directory ▸ stake-pools.sqlite file

there are other files that can be safely deleted to help reset the entire wallet, but this clears the locked stake pools issue
good luck and happy staking, earned my first rewards!

Worked here too. Straight forward.