Daedalus wallet and spending password i never even heard of till i tried to transfer coins out of wallet?

I could use some help, i set my Daedalus wallet up it asked me to create a password and i did and wrote down along with 12 word phrase but no mention of a so called spending password. I had no problem transferring ada from binance to the ada wallet but now trying to transfer some back to binance its asking for this spending pw??? I tried the only pw i setup and it doesn’t work?? Any help would be appr

The spending password is the only password asked for during setup. Use that one. If it doesn’t work then your password hint might be Jack Daniels (just kidding). Hope you get it sorted.

You can always rebuild the entire wallet from scratch with the 12 word seed.


Hi @harryt17,

Sorry to hear about your situation. Are you able to generate new addreses with the password that you currently have for your wallet?

yes i can generate a receive address but it doesn’t ask for a pw? ugh

That’s bizarre, because it should prompt you to enter your PW everytime you want to generate a new address. Hmm

1 Like

i wrote the pw down when setting up, dont get it, it wasn’t the latest updated version of wallet. never asked for pw when i sent ada to wallet

should i uninstall Daedalus wallet and try 12 word phrase to get it funds back? i am not tech savy like some

Just to be clear, you will not be prompted to enter PW for an existing address, only for new addresses. You can choose to generate multiple addresses for the same wallet. This features allows more privacy…

i just looked, i copied generated address and not the generate new address that has a pw option??

i sent it to the generated address i copied at the bottom? ugh

Could you please try generating a new address?

i tried to and entered pw when i setup wallet and it says pw invalid?

incorrect to be exact

Should of kept it on binance! was trying to keep in in a safer place but i guess i screwed myself

Ok, that’s what I suspected. It’s not recognizing your only password. I think restoring your wallet with the 12 words would help, but just to be sure I will refer you to more tech savvy and respected contributors.

Perhaps @vantuz-subhuman or @werkof or @RobJF or @ZCryt0Knight could help?

1 Like

ok, is there a support link directly to cardano or Daedalus?? can’t find on

As long as you have the original 12 words you will be OK.

Maybe try this video https://m.youtube.com/watch?v=h3RLQvCV2zM

And if the video does not help, click on the bug :beetle: icon at the bottom left corner of your screen and it will take you to the settings–>support tab where you can find all your tech support options. Pic below…


1 Like

So, if I understood correctly, did you create the wallet and write the 12seed on paper, and also set an spending password without remembering it now?

If this is the case you can restore your wallet on the same or another computer by inserting your 12seeds passphrase. Then you can set a new spending password and access the existing wallet.

Depends on you if you first remove the existing wallet (no need to reinstall the entire Daedalus) to restore the same wallet on the same computer, or if you prefer restoring your wallet on another computer before you change anything on the existing setup.

I likely wrote down the password incorrectly. Restore the wallet. That solves the problem. Keeping it on binance isn’t s great idea but hey it’s your money.

same here ask for same 12 seed words and againg it says invalid, then I clk my second address in the same wallet and clk restore and at the moment it is donwloading/updating it says 1hr or more to go patiently wating.