Can not set a spending wallet password. locked out

I tried to update mainnet to current version, downloaded it installed, i got pop up saying virus in macafee. If that helps!! anyway it wudnt let me open with link on my desktop, said no longer can be found, so i uninstalled daedalus, and reinstalled 4.1.1, it synced and in the background i cud see my balance, it said i had to enter a spending password, which i had never been asked for 6 months ago, if i enter a password it says its wrong, so i cant delete the current wallet, as im froze out, whats the problem!!! help please asap!!! P.S im using a ledger nano x with passphrases

Hello @charlee

Restore your wallet with the secret words (seed / secret phrase), you will be requested to set a new spending password (please remember to keep it in a safe place this time). Do not delete the current wallet until you have restored it.

Greetings, Nápoles.

1 Like

I did that and it made a new wallet with no ada in, the wallet with the ada in is still there, but u cant delete it, u cant do it without the password

If the wallet has no balance, it means that it is not restoring the secret phrase correctly. If a word/letter is changed, a new wallet will be restored, not yours. Here is a complete list with all possible words.

but u cant have 2 wallets with the ada in, so i believe i nee to find a way to delete the wallet with the ada in, before installing a new one??? im stuck??

also im using a ledger!!!

Your wallet won’t need a password if you are using ledger. The ledger is the password/lock. And you shouldn’t create a new non hardware wallet in daedalus. If you do this then the new wallet will be empty since it’s not connected to your ledger.

Easiest thing to do first is go to adalite.io and connect with your ledger. So don’t create a new wallet. Now you should see your balance. Correct?

if i go to adalite with ledger it shows the balance as correct its on the ledger. But on daedalus it will not work, it asks for spending password. so cant delete, if i try to pair, by clicking at new wallet, it asks for export public key which i do, and it goes to wallet alredy exists.

This is the story so far:
Cant restore wallet, spending password stopping me.

I had to redownload Daedalus program. I was asked to set a spending wallet password. Then retype the password. When I do it keeps saying it’s invalid. I am sure I am retyping it correctly. Also the password strength is strong. This is the first time this program asked me to set a password. I can’t get to my ADA.
Is there a way of bypassing this section??? Someone please help!!!

I did not even get to the point to restore. After the program synched with the block chain, it asked went to the window that reads: " Your wallet is not protected with a spending password. To keep your wallet secure and using it in Daedalus, you need to set a spending password" Then when you click on the Set a Password box. It allows you to create a password, which I did create a strong password as it indicates. When I go to retype the password it says, “invalid wallet password”. I know for sure I am typing in the same password.

So i tried the restore added my ledger nano secret keys, and it installed a blank wallet with zero ada in it, the other wallet is still there with the ada in, but cant get to it due to this password problem, it seems obvious you cant have 2 wallets with the ada in, so do u think i need to find a way to delete the wallet with the ada in first, theres the problem how???

So far so good.

Now I am assuming you have the most recent version of daedalus installed (which is 4.1.0). If not, do that first please.

Then if you start Daedalus you see 2 wallets, right? One of the 2 wallets has an hardware wallet icon at the right side of the wallet name. Right?
If yes, the name of this wallet should be the same as shown in adalite, correct?
If yes, this wallet in daedalus is your ledger wallet.
Now when you just click the ledger wallet in daedalus, it asks for a password immediately? or only when you want to send some ada to another wallet? It shouldnt ask you for a password just when you click the wallet. If it asks a password when you want to send a transaction then your ledger probably has a passphrase. That is additional security you configure in your ledger software. Let me know what you find.

was all to do with when i downloaded update my macafee quarinateed a file, as a virus, i risked restoring it, and it worked straight away, all unlocked and full access, not spending password needed, i thx u for your help, thought i wud let u no outcome, im sure somebody will have same problem. cheers.

1 Like

With that in mind, is it possible to know which Daedalus file was detected as suspicious by McAfee and thus quarantined ? Was it the main executable ?