Spending password for ledger wallet on daedulus new update

Hi all, I’m currently using the daedalus wallet and I’ve just installed the new update.
After updating I’ve tried to access my ledger wallet and it’s telling me I need to create a spending password for my ledger wallet.
But everytime I try and set the password it says incorrect wallet password?
Is there something I’m doing wrong totally new to this stuff so any help is much appreciated. Thankyou.


Didu installed the daedalus 3.3.0 from official site right? Not for mobile, etc…


Yea correct installed to official wallet. I can see the wallet there but when I click on it I keep getting set new spending password. When I try to set one I keep getting wrong wallet password.

Did u tried to restore ur wallet by pairing again the ledger to daedalus?

Yea I did try that and it says wallet already exists so unable to do that either . Thankyou so much for your reply as well been trying for hours to sort this out

Yes, it’s saying wallet aleeady exist… because u need to deletw the wallet from daedalus first.

How do I do that when I can access the wallet to delete it tho ? As soon as I select it I get your wallet is not protected with a spending password.

But, did u tried the ledger pin?

Till u will solve the daedalus “issue”, u still have other 2 options to accees ur ledger wallet:


Ok so if I download the yoroi extension I can pair my ledger to there and have full access? Thankyou

Yes, be carefull to dowoad the official version… a lot of scams these days…

Ok thankyou so much Alex

1 Like