Failed to start Prometheus.service

Was working fine, and then I made a back up of my servers which rebooted my servers. And now prometheus isnt working.

Can u use this command?

journalctl -e -f -u prometheus.service

I had this issue too and I modify the yaml config… I checked to have only spaces inside yml config (not TAB, etc)



Yeah … I saw the “instance” line are not same for all … first one has more spaces than the rest… I tried to keep the right format otherwise everytime I had errors

Well if I copy the Coincashew guide exact this is what I come up with:

With this one … the service (prometheus) starts?

No it doesnt:

Can u try

systemd-journalctl -e -f -u prometheus.service

systemd-journalctl -e -f -u prometheus.service
systemd-journalctl: command not found

Do u have also node exporter here?

sudo systemctl status node-exporter
I think this is the right command

e$ sudo systemctl status prometheus-node-exporter.service
â—Ź prometheus-node-exporter.service - Prometheus exporter for machine metrics
Loaded: loaded (/lib/systemd/system/prometheus-node-exporter.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2021-03-12 09:21:37 EST; 11min ago
Docs: GitHub - prometheus/node_exporter: Exporter for machine metrics
Main PID: 450 (prometheus-node)
Tasks: 5 (limit: 9418)
Memory: 10.9M
CGroup: /system.slice/prometheus-node-exporter.service

I had this issue… prometheus wanted to start… and I deleted all empty spaces and I added space by space… after this it’s started

I dont know what you mean remove the spaces.


“Block-Producer” instead of “Block Producer” :slight_smile:

No change:

its working now, I removed static_confiigs: at the bottom and it started working.

The names are showing up weird in Grafana:


U must edit the legend field in grafana for each pannel;
u need to write {{alias}}

they all say alias: