Following CoinCashew for a new pool setup ./gLiveView not starting

It is likely that you’re using master instead of 1.24.2 node version. Please do not use unsupported tags against tools.

PS: EKG should remain at 12788, 12798 is for prometheus in default configs.

I’m not sure what I did to make it work unfortunately. I was modifying the env variables and got lost at my step, so I deleted env and ./ can curled a fresh copy of both. I restarted the node service and went for a hike. When I got back, I tried gLiveView again. It flashed “Guild LiveView version check…” then started working.

When I first saw the UI, both nodes were ~53% synced. To that point, I had followed CoinCashew’s guide as closely as possible. I would recommend removing env and ./, curling new copies, chmod gLiveView again, restart the cardano node service, wait an hour or two, then try it again.

Sorry I don’t have specifics on what made it work. I wasnt documenting it very well. This is one of those “task failed successfully” moments.

I doubt following the bouncing ball ended in me running master instead of node. Other ways you would see more instances of this popping up.

Screen Shot 2021-01-19 at 9.50.32 AM

Transactions started counting up late last night, however still not data for Density or Epoch.

Using EKG set to 12788.

Also, I feel something to note, these same data points that are not showing up in gLiveView are also not showing up in prometheus.

Dear mraybin,

They updated the config files which do not work with gLive yet.

For example for mainnet the problem is solved with this config file
wget -N
sed -i ${NODE_CONFIG}-config.json
-e “s/TraceBlockFetchDecisions”: false/TraceBlockFetchDecisions": true/g"

For testnet you should be able to look it up. Or maybe you have somewhere an older version of testnet-config lying around.

Hope it helps.


I am on mainnet


as I understood you have an error starting your glive right?
your node is up and running?
how do you start your node, as systemd or manually? do you use cntools?


Then at least this config file should be up to date.
wget -N
sed -i ${NODE_CONFIG}-config.json
-e “s/TraceBlockFetchDecisions”: false/TraceBlockFetchDecisions": true/g"



Ofcourse one has to restart the node after the main-config is updatet.


This 100% solved my issue. Thank you.

I am happy to help!

Gimme a like please :smiley: and we are even haha

see ya around!


Done and done :slight_smile:

1 Like

Just adding my 2 cents. If you are using cntools/ coincashew’s guide… it will start eventually but you need to be patient.

At step 4 (coincashew - Start the relay node) - after you’ve started the node, check the status, if it says active… Take a 4 - 5 hour break.

You dont need to do anything else. gLiveView will not run at the beginning, ive seen videos on youtube where it works right away… but thats not the case for us.

After it sync’s over a certain percentage gliveview WILL run. I tested this theory when setting up my producer node, and initially it wasnt working… gave this same error (expected). I went to bed and about 6 hours later i ran gliveview again and it ran without issues. So be patient


This is good advice. I don’t think patience and setup go hand in hand most of the time :).

1 Like

So… more on this after the 1.25.1 update. Now when trying to run gLiveView I get this.

It seems your /home/cardano/cardano-my-node/mainnet-config.json file was not upgraded from version before cardano-node 1.25.1. Please download it from guild-operators repository!

Anyone have an updated solution? Running the previous solution seems to be no longer a valid solution.


Follow what the error suggests (the config is available on hydra as well as guild-operators repository), it’s quite clear what script is asking if you actually go through release notes of cardano-node 1.25.1

1 Like

so I ran this:

wget -N{NODE_BUILD_NUM}/download/1/{NODE_CONFIG}-config.json
sed -i ${NODE_CONFIG}-config.json
-e “s/TraceBlockFetchDecisions”: false/TraceBlockFetchDecisions": true/g"

no joy.

EDIT: JOY… This did work, just needed to restart and wait for transaction count to start going up :wink:

1 Like

now you have the latest file released for 1.25.1 version

Correct. Actually, just did another restart this morning. Waited until transaction count started going up and ran gLive again. That time it worked so it looks like that bit was a good solution for 1.25.1

Ah crap, Now I am back to my original issue, gLiveView starts but is stuck on starting… and does not show epoch or kes info :confused:

wait, it will take more time… how do you start the node? as systemd? or manually?