Get an error trying to send funds from node

im trying to register my node and i get this error when trying to send the funds

Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (MissingVKeyWitnessesUTXOW (WitHashes (fromList [KeyHash “7372ec14afbc3476886a914ceda3d1b9252c074b90d784ac9b3d01ae”,KeyHash “eb1c24e8bdfa4be0305c09c695cdb8526c470142d51544c8453cca03”,KeyHash “fa148cf300e6b91ca4fe18b23d92ef589e484dd3a337808d1767b6b1”])))),UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (OutsideValidityIntervalUTxO (ValidityInterval {invalidBefore = SNothing, invalidHereafter = SJust (SlotNo 40762449)}) (SlotNo 40762470)))),DelegsFailure (DelplFailure (DelegFailure (StakeDelegationImpossibleDELEG (KeyHashObj (KeyHash “fa148cf300e6b91ca4fe18b23d92ef589e484dd3a337808d1767b6b1”)))))])

Hi. Please provide the commands you are executing.

cardano-cli transaction submit
–tx-file tx.signed

We’ll need the other ones as well as it seems that you did not build the transaction correctly. You can mask sensitive info if there is any.

im using this guide Guide: How to build a Cardano Stake Pool - CoinCashew
stuck at regestering you stake address.

i also had the same error trying to move funds using Guide: How to build a Cardano Stake Pool - CoinCashew

ill give a more detailed answer in a little while have to pick up my kid

1 Like

cardano@ADAserver:~/cardano-my-node$ currentSlot=$(cardano-cli query tip --mainnet | jq -r ‘.slot’)
echo Current Slot: $currentSlot
Current Slot: 40776830
cardano@ADAserver:~/cardano-my-node$ amountToSend=10000000
echo amountToSend: $amountToSend
amountToSend: 10000000
cardano@ADAserver:~/node adresscardano@ADAserver:~/cardano-my-node$ echo destinationAddress: $destinationAddress
destinationAddress: my wallet
cardano@ADAserver:~/cardano-my-node$ cardano-cli query utxo
–address $(cat payment.addr)
–mainnet > fullUtxo.out

tail -n +3 fullUtxo.out | sort -k3 -nr > balance.out

cat balance.out

while read -r utxo; do
in_addr=$(awk ‘{ print $1 }’ <<< “${utxo}”)
idx=$(awk ‘{ print $2 }’ <<< “${utxo}”)
utxo_balance=$(awk ‘{ print $3 }’ <<< “${utxo}”)
echo TxHash: ${in_addr}#${idx}
echo ADA: ${utxo_balance}
tx_in="${tx_in} --tx-in ${in_addr}#${idx}"
done < balance.out
txcnt=$(cat balance.out | wc -l)
echo Total ADA balance: ${total_balance}
echo Number of UTXOs: ${txcnt}
e42f1d0ce0219a91144ebc86bac1c05d05b4066d587adc31b75bae08cda5304d 0 502817955 lovelace + TxOutDatumHashNone
360f34c13440b0fb94d13abd87b67e8c586d14a8610fa7b1ca4f23a777807829 0 500000000 lovelace + TxOutDatumHashNone
TxHash: e42f1d0ce0219a91144ebc86bac1c05d05b4066d587adc31b75bae08cda5304d#0
ADA: 502817955
TxHash: 360f34c13440b0fb94d13abd87b67e8c586d14a8610fa7b1ca4f23a777807829#0

ADA: 500000000
Total ADA balance: 1002817955
Number of UTXOs: 2

cardano@ADAserver:~/cardano-my-node$ cardano-cli transaction build-raw
–tx-out $(cat payment.addr)+0
–tx-out ${destinationAddress}+0
–invalid-hereafter $(( ${currentSlot} + 10000))
–fee 0
–out-file tx.tmp
cardano@ADAserver:~/cardano-my-node$ fee=$(cardano-cli transaction calculate-min-fee
–tx-body-file tx.tmp
–tx-in-count ${txcnt}
–tx-out-count 2
–witness-count 1
–byron-witness-count 0
–protocol-params-file params.json | awk ‘{ print $1 }’)
echo fee: $fee
fee: 179933
cardano@ADAserver:~/cardano-my-node$ txOut=$((${total_balance}-${fee}-${amountToSend}))
echo Change Output: ${txOut}
Change Output: 992638022
cardano@ADAserver:~/cardano-my-node$ cardano-cli transaction build-raw
–tx-out $(cat payment.addr)+${txOut}
–tx-out ${destinationAddress}+${amountToSend}
–invalid-hereafter $(( ${currentSlot} + 10000))
–fee ${fee}
–out-file tx.raw

then i send the tx.raw to my cold machine and run

cardano-cli transaction sign
–tx-body-file tx.raw
–signing-key-file payment.skey
–out-file tx.signed

then move tx.signed to my hot

then i get the error
cardano@ADAserver:~/cardano-my-node$ cardano-cli transaction submit
–tx-file tx.signed
Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (MissingVKeyWitnessesUTXOW (WitHashes (fromList [KeyHash “7372ec14afbc3476886a914ceda3d1b9252c074b90d784ac9b3d01ae”,KeyHash “eb1c24e8bdfa4be0305c09c695cdb8526c470142d51544c8453cca03”,KeyHash “fa148cf300e6b91ca4fe18b23d92ef589e484dd3a337808d1767b6b1”])))),UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (OutsideValidityIntervalUTxO (ValidityInterval {invalidBefore = SNothing, invalidHereafter = SJust (SlotNo 40762449)}) (SlotNo 40777424)))),DelegsFailure (DelplFailure (DelegFailure (StakeDelegationImpossibleDELEG (KeyHashObj (KeyHash “fa148cf300e6b91ca4fe18b23d92ef589e484dd3a337808d1767b6b1”)))))])

This is not a real address.

that was just me censoring it i put the actual address in there

1 Like

Someone can get the address from the transaction ids above. But no worries, those are just receiving addresses.

Looking through the transaction build process everything looks good.
There is also an error about the validity interval:
invalidHereafter = SJust (SlotNo 40762449)}) (SlotNo 40777424))

I assume you signed the transaction and tried sending it just after you created it, and not several hours later?

yes i sent it right away well i think i used an old transation just ti show the process

so im stuck? or is there a way to send the funds back to where they came from?

Sorry, I’m a bit confused so need clarification.

The first message says you are trying to register the node.
The sample provided is for sending a simple transaction.

Is the error below the sample the actual error after those commands have been run?

If not please could you provide the commands for how you are registering the pool? According to the error, it seems like you forgot to sign the transaction with all keys in case you are trying to register the stake pool.

Please clarify where in the process the funds got lost? Do you mean the 500ADA to register the pool?

the last transaction i tried was to move 10 ada to my daedalus wallet im scared i over wrote the key and can’t get the funds out

The private key (payment.skey) ? I suppose you don’t have a backup?

i do not have a back up first timer is that wasn’t clear

Oh no :confused: Are you sure you overwrote it ? Maybe you moved it somewhere?

just looked through everthing i lost the original skey so i guess im stuck

Go through the bash history, if you overwrote it there must be some evidence, like some command which did it… I still hope you just moved it or something.

List the command line history:
history | more