Getting started with cardano node simple transaction question

I am trying to setup my own stake pool out of curiosity, so I have been following along the official instructions on the Cardano docs, and I have a question about the third step :

When I get the transaction hash, I don’t have any rows displayed, unlike the example with command cardano-cli query utxo \ --address $(cat payment.addr) \ --mainnet.

I just get

TxHash TxIx Amount --------------------------------------------------------------------------------------
I imagine I need to send ADA to the node’s address or something? But I didn’t see any mention of that earlier in the guide, so I’m not sure how to do so.


1 Like

Hi, I’m getting same response (just using testnet instead of mainet). Here: Error on the Query the balance of an address (Solved) they say it can be a sync issue, and after some time should be OK. Anyway I’ll leave my node to work over night and maybe tomorrow expected result be there.

might be a stupid question, but do you have the payment.addr file where you are running the command? run “cat payment.addr” separately to see if you have a good looking address as well

or have you tried to punch in the actual address in the command replacing $(cat payment.addr)?

i am getting the same output. checked the payment… did you solve the problem? @tzeee

Also is your node fully sync’d with the blockchain?

I think you will only see a row if there the wallet at payment.addr has ADA. Once you send some ADA to the payment.addr then the tx will show up along with amount of ADA.