gLiveView: Process is working but there appear to be some details that look wrong

So I’ve been working on a Cardano Testnet staking pool and want to ensure that we are able to mint blocks before our team goes to the mainnet. However, I’ve had the pool running for almost 2 months now with no blocks minted at all.

I’m running cardano-node/cli version 1.32.1
GHC version 8.10.7
Cabal version

From the gLiveView output, there are a few things that are concerning. The error (process ID list syntax error at the top) and “Syncing” field that remains at 94.4%. Since i’m newer to using this tool, I don’t know if there are particulars that don’t appear correct to the layman. Is it also okay for me not to have P2P (I have most ports blocked to enhance security but could certainly be overdoing it)?

It looks like the node stoped syncing … now on mainnet we are in epoch 314
the syncing process is working or it’s stucked? Also I don’t see any OUT peers

can u add the IOHK nodes inside the topology file and restart the node?

Or u can download the mainnet-topology.json


Seems as if it’s on testnet:

After doing a bit more research, it appears that I was supposed to have the topologyupdater announcing my relay to the network (guild-operators/ at alpha · cardano-community/guild-operators · GitHub). I have set this up now as well as the services they recommend. Would that be all I needed for this to start showing correctly? It already looks a lot different for the view.

what port did u used to start the node?

I used port 3001

Then open env file and replace CNODE_PORT 6000 with 3001, save the file and check again on glive

Doing that resulted in a new error message:

ERROR: You specified 12788 as your EKG port, but it looks like the cardano-node (PID: 19023 ) is not listening on this port. Please update the config or kill the conflicting process first.
ERROR: gLiveView failed to load common env file
Please verify set values in ‘User Variables’ section in env file or log an issue on GitHub

Do I need to turn off my node before it will operate?

Restart the node

Done. The same error is produced. I also tried changing the EKG from Y to N and was provided another error but from the prometheus port similar to the EKG port

You must kill all the processes… try to reboot the server

After full restart I still receive the same error message.

check inside the start script which cnode did u set to start the node, that port should match with cnode port from env file

Does it matter that my relay node and block producing node are set to 3001?

nope, you can set any ports you will want, but that port should be also set inside env file for glive

The port matches in the env file. Still getting the same result. Would this be the result of a dependency issue?

Did u followed coincashew guide right?
Then the start up script should be

cat > $NODE_HOME/ << EOF 
/usr/local/bin/cardano-node run +RTS -N -A16m -qg -qb -RTS --topology \${TOPOLOGY} --database-path \${DB_PATH} --socket-path \${SOCKET_PATH} --host-addr \${HOSTADDR} --port \${PORT} --config \${CONFIG}

Run the following to modify env with the updated file locations.

sed -i env \

-e "s/\#CONFIG=\"\${CNODE_HOME}\/files\/config.json\"/CONFIG=\"\${NODE_HOME}\/mainnet-config.json\"/g" \

-e "s/\#SOCKET=\"\${CNODE_HOME}\/sockets\/node0.socket\"/SOCKET=\"\${NODE_HOME}\/db\/socket\"/g"

also inside env u should have the cnode port set to 3001


PS: I see by default the cnode port inside the env file is commente, so please uncomment the line (delete # from the begining)

I have all of that set up and it appears, at least I think, to be working correct for the relay server. However, my block producing server still looks odd in comparison for the gLiveView.
here’s the output from the relay

and here’s from the block producer

Is it possible that my block producer isn’t receiving communication from my relay? I guess I just don’t get why it says “syncing 94.4%” when both the relay and block producer are fully synced.

Hmmm, strange… can u type top? How many cardano-node processes do u see?
How do u know that the nodes are 100% synced?

PS: is strange because in glive I still see the port 6000 instead of 3001

I only have one cardano-node according to top

I have the gLiveView using the defaults for the env file. Switching the port to 3001 causes the EKG error listed above and doesn’t allow me to see gLiveView at all. Does the relay node look good through the gLiveView at least?