Guild Live View in and out who should be listed on in?


i just create a pull, and i install Guild Live View, i have at the moment my block producer node and my relay, in same network,

my question is, on relay Guild Live View, where i should see my block producer node? Only on out connection or also at in ?

Because at the moment i see only in out connection as first of the list, and the same also is in block producer node.

That is correct or in the relay node, i should see my block producer node on the in peers ?

Thank you.

And sorry if it sound stupid but i need to know if i make all correct.

yes, both nodes should be seen as IN/OUT peers, if u see the BP only in OUT peers it means that the relay connected to BP but the BP didn’t connected to Relay

try from BP

telnet Relay_IP Relay_port

do u see connected?

Thank you for your answer,

this is what i get

Connected to
Escape character is ‘^]’.
Connection closed by foreign host.

and same is if i use my local ip

then check the fw… on ur relay did u opened the port to allow connections from any? U are using the default port 6000 right?

and also are the nodes 100% synced?

Yes all Sync , and firewall is set correctly.

Maybe I did something wrong with the port.

As in block producer I use 6000 and in relay node 3001

I will try to check configuration and forwarding better . And let you know the results.thannks

And did u started the node with port 3001? Can u share the glive?

Really node


This is after your tips.
But still only on producer node I can see in and out

And in the relay node only on out, but not blockproducer on in peers

But u said u used 3001 for Relay but the relay is started with port 6000 so, in order to solve the issue u have 2 options:

  • go to BP topology file and set the port 6000 for Relay (according to glive output the Relay is running on port 6000) save the file and restart the node
  • go to Relay and start it with port 3001 (u will need to edit the cnode_port from env file - replace 6000 with 3001, u will need to edit the script - replace 6000 with 3001, edit also the script - replace 6000 with 3001; restart the relay

Thank you.

You help me a lot.

It looks great now.

I will let you know

1 Like