How to restore my Yoroi hardware wallet without losing my ADA?


I’ve had a problem with my desktop. My hard disk is broken. Now I’ve a new hard disk.

I’ve downloaded the last version of Ledger Live in Windows and I’ve updated the firmware and the app of Cardano in Ledger Live.

When I’ve tried to restore my Yoroi wallet I couldn’t. On my computer screen it said me: “emurgo asks to connect to a device HID”. And after it said me: “It happened something. Please try it again.” At the same time in my Ledger hardware when I press the two buttons with the word Cardano it doesn’t appear “Export public key”, only “Waiting for commands and version 2.3.2”

I’ve some ADA doing staking. Perhaps it’s for that I don’t have the words Export Public Key in my Ledger. What do you think?.

I just want to restore my Yoroi hardware wallet and to recover my ADA.

I’ve thought to restore my hardware with a recovery phrase, but am I going to lose my ADA?.

If I’d a paper wallet or a physical wallet I could restore my wallet because I’ve my recovery phrase. And in this case it’s not important to have the cryptos doing staking. They don’t ask Export Public Key. It works only with the recovery phrase.

What to do?.


Hey @Gustavo

Dont worry we will fix that issue easily :slight_smile:

What OS do you use on your computer? Which browser do you use? And yes you have to export your public key (dont mix it up with your private key which has to keep private^^ )

Also please dont use your 24 word from your Ledger to restore your wallet in Yoroi. If you already did that, you probably should get a new seedphrase asap.


1 Like

Thanks for your answer.

I use Windows 10 and Google Chrome in my computer.

If I restore my hardware with my seed words I don’t know if I’m going to lose my ADA because I’ve to install the apps as Cardano. And now I’ve installed it.

Real quick, never give your seed words to anyone or anything (especially apps). Ever!

These sorts of things are for paper backups in a fire proof safe that only your wife and favorite children know about for any non-trivial amounts of crypto.

Next up, your ledger should have come with some handy note cards to write down your seed words that you would never tell anyone about and put in that safe somewhere you also wouldn’t talk about.

Lastly, now might be a good time to go find those seed words and restore your wallet elsewhere.

If you did not verify the Ledger app signature after downloading or are worried about your OS being compromised then it might also be a good time to transfer your holdings to brand new wallet address.

Note: the entire additional security of a hardware wallet is that the private key is never exposed so if you typed your seeds words on ANY keyboard at any point you need to VERY quickly transfer your funds to a new wallet !!!

Good luck!

Try to connect your ledger via to check if everything is working.

If that works, try to connect it via Yoroi again. Search on Youtube for any guides if you dont know how to do so.

Make sure you are using the most recent versions of Ledger Live, Ledger firmware and the Cardano app on your Ledger device.

Thanks for your advice!

I’ll try. Let’s see.

It’s solved!

When the app says “emurgo asks to connect to a device HID” I should have selected Nano X and press the button Connect.

Thanks everybody!.

1 Like

Hi Zyroxa!

Thank you very much.

We’ll be in contact. I’m in the forum now!. There are good people to know.

Have a nice day!

1 Like