I can't register my staking certificate

I’ve a synced node running on itn-shelly-testnet,
but i’ve the same problem, I send the stackpool certificate on the blockchain but doesn’t get registered, probably because I’ve only 0.50 ADA on my account: addr1sh678xnlexthq6m3k4eqjfyqh3az3dfspphppu8vrg46nw363lj4jfr4yz5
and as far I understood I need at list 560.00 ADA.
I’ve tried to use a faucet with cmd:
curl -X POST https://faucet.itn_rewards_v1.jormungandr-testnet.iohkdev.io/send-money/$ADDRESS
but doesn’t work.

Can anyone please send me some ada?

Thanks a lot.

Hello @stefanosu,

please note that your post was moved from the other topic, this has nothing to do with registering meta data on the repo of the Cardano Foundation.

It’s important to understand two things here:

  1. you need 500 ada to pay for the on-chain registration of the pool + some small fee.
  2. there are several testnets: https://hydra.iohk.io/build/1523436/download/1/index.html the incentivised testnet is called “itn_rewards_v1” - in this testnet there are no faucets (because you would get real rewards from that)

To get ada in the itn_rewards_v1 you have to restore a wallet that had ada when the snapshot for this testnet was taken. (12:00 UTC on November 29, 2019)


Yes I knew about the snapshot,
but at that time I didn’t know that I need 500 ADA for stack pool on-chain registration
and I had a yoroi wallet with only 20 ADA,
for that I was asking itn_reward_v1 ADA coins.

Can anyone exchange 500 ADA on itn_reward_v1 with real 20 ADA on mainnet?
so I could try to register my little private pool.

Plese send ADA to itn_reward_v1 address:
and write to me the real address to give the 20ADA back.
Thanks a lot.

I solved the sync problem adding in node_config.yaml
the listen_address and public_address since I’m behind a NAT router like this:

“p2p”: {
“listen_address”: “/ip4/”,
“public_address”: “/ip4/79.xx.xx.xx/tcp/3100”,
“topics_of_interest”: {

I could be wrong on this, and this is not the first time I’ve seen this, but you might have a configuration problem here, because 3100 is the default REST port. (depending on your setup though)

You should not expose the REST port to the outside world, otherwise one can think of nasty things like shutting down your stake pool with only a browser.