Pool just created: not appearing on adapools or Yoroi delegation list

Hi. @Alexd1985 or whoever

If you don’t mind: I just created my pool using Coicashew’s tutorial.

All checks so far seem OK. Nodes are in sync. But I cannot find my pool on adapools or similar. It doesn’t show up on Yoroi’s delegation list either.

My pool ticker is ATILS (Atlantis Staking Pool)
Pool ID is: 0b930bd8da4b2bef552cdf5a85fd67261547877674ecf43a5368bee6

When I run:
cardano-cli query stake-snapshot --stake-pool-id $(cat stakepoolid.txt) --mainnet

I get:

    "poolStakeGo": 0,
    "activeStakeGo": 23411124422164299,
    "poolStakeMark": 0,
    "activeStakeMark": 23478023193513019,
    "poolStakeSet": 0,
    "activeStakeSet": 23445774697795279

Yet it’s still not showing


Then how did u registered the pool? U mist wait first for the nodes to be 100% synced then register again if still not visible

He mentioned nodes are in sync :slight_smile:

Just to make sure, have you published the transaction with the appropriate certificates? (pool certificate, delegation certificate)

If you are not sure maybe you can paste all the steps done to register the pool.

if the nodes are in sync… will not work anything… the transactions not been submitted to the blockchain

I followed steps 11 and 12 according to Concashew’s guide:

Hey yllanos

I’m curious if you are able to see the balance of your payment address has decreased by about 502 ADA including the stake address registration (2 ₳) and the pool registration (500 ₳)? That should tell you if you submitted the transactions.

cardano-cli query utxo \
  --address $(cat payment.addr) \

I know in my case, I had a mismatch of the hash of the poolMetaData.json file, which prevented my pool from showing up on pooltool.io. To fix that issue, I had to re-register the pool.cert after recalculating the poolMetaData.json hash. You do NOT need to re-pay the pool registration fee of 500 ₳ on subsequent re-registrations.

Here’s how I recalculated pool meta data hash

# On hot node
# Fetch the raw poolMetaData.json file into a file called rawMetaData.json
wget -O rawMetaData.json <shortened_URL_to_raw_poolMetaData_json_file>

# Use CLI to calculate metadata-hash for the fetched file and write to output file
cardano-cli stake-pool metadata-hash --pool-metadata-file rawMetaData.json > poolMetaDataHash.txt

#Go through the process to re-register pool.cert using correct hash value
1 Like

I’ll try this as soon as I have some time. I will update by then.



I’m closing this one. In the end I decided it wasn’t worth to do a full investigation on this, so I recreated my node from scratch. It works now.

Thanks all

1 Like